summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-22 20:57:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-22 21:14:43 +0200
commit0c5f5f1b7b69cea2a15241ca32a7f30e2ba76b01 (patch)
tree7706503e1bc1ccd8734ea39c096742a7eacc4439 /dev-python
parentdev-python/pyhamcrest: Bump to 2.1.0 (diff)
downloadgentoo-0c5f5f1b7b69cea2a15241ca32a7f30e2ba76b01.tar.gz
gentoo-0c5f5f1b7b69cea2a15241ca32a7f30e2ba76b01.tar.bz2
gentoo-0c5f5f1b7b69cea2a15241ca32a7f30e2ba76b01.zip
dev-python/construct: Bump to 2.10.69
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/construct/Manifest1
-rw-r--r--dev-python/construct/construct-2.10.69.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/construct/Manifest b/dev-python/construct/Manifest
index 4b506f194ae9..ff52be77af96 100644
--- a/dev-python/construct/Manifest
+++ b/dev-python/construct/Manifest
@@ -1 +1,2 @@
DIST construct-2.10.68.tar.gz 1190512 BLAKE2B b41e5b3b62cd1568c78ac4975b0d66e7a7ad4489e97031d3e866ff8eb98eea4eb387041dce15210304c608e0c419548cddea3557c2f53d52ecbcf6eb5be67749 SHA512 2388751323b16b69a06457c4862e7d1334580c201050734f150ab4437e2066ed18ff5323f7d81b8bb93124ae0f57a2ae91d7c64ffefc6e0369d6e625b7fef4eb
+DIST construct-2.10.69.gh.tar.gz 1195652 BLAKE2B 003353d4be4992ecb9e32b845a35a4850f451e3ead40af2c1b9d3380c27b58088e75e20ff76c733e573594e1ae08406c188868907c0f335c13e23cb01bf7481f SHA512 c94a1b3a62c9bf4aed30eb262d4439452f98fe909e399d79ece8da4aa707f95c754d540672c2cc9c307425914e43384b5455eb7970ab5d7830af1c0b06313f9e
diff --git a/dev-python/construct/construct-2.10.69.ebuild b/dev-python/construct/construct-2.10.69.ebuild
new file mode 100644
index 000000000000..a5baf8b6e5fa
--- /dev/null
+++ b/dev-python/construct/construct-2.10.69.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A powerful declarative parser for binary data"
+HOMEPAGE="
+ https://construct.readthedocs.io/en/latest/
+ https://github.com/construct/construct/
+ https://pypi.org/project/construct/
+"
+SRC_URI="
+ https://github.com/construct/construct/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/lz4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.15.4[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/test_benchmarks.py
+)
+
+pkg_postinst() {
+ ewarn "Version 2.10.x has significant API and implementation changes from"
+ ewarn "previous 2.9.x releases. Please read the documentation at"
+ ewarn "https://construct.readthedocs.io/en/latest/transition210.html"
+ ewarn "for more info."
+}