summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-26 22:13:18 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-26 22:14:53 +0200
commit0d4169fa343bfc44dd299eb2eb9ff791ecf0adc1 (patch)
treeebcc5fd6f8f34660042c78f786f48229e9be855b /dev-python
parentdev-python/python-lsp-server: add version 1.1.0 (diff)
downloadgentoo-0d4169fa343bfc44dd299eb2eb9ff791ecf0adc1.tar.gz
gentoo-0d4169fa343bfc44dd299eb2eb9ff791ecf0adc1.tar.bz2
gentoo-0d4169fa343bfc44dd299eb2eb9ff791ecf0adc1.zip
dev-python/tikzplotlib: add version 0.9.9
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tikzplotlib/Manifest1
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
index 9579a28104af..babedf634366 100644
--- a/dev-python/tikzplotlib/Manifest
+++ b/dev-python/tikzplotlib/Manifest
@@ -1 +1,2 @@
DIST tikzplotlib-0.9.8.tar.gz 589858 BLAKE2B 81bb2ece7d3f5976d928095caa3d8d51b619c97a4b36eea14f4b4477d31e78a978c2eeab81e9829bb9113e70f0035a572a82a229fea61ee08530d57334fda986 SHA512 a2b25d9820fd8185d4e7a03fb0669fa4c9b35aac9b371b0a873174d615bd40615f1fafa4208d2019af0b7ffe80a8eec6b56ad6075104f6c3a4f8f237ad5b4466
+DIST tikzplotlib-0.9.9.tar.gz 591659 BLAKE2B c8ed8069387aedc154ea1541c7e4f97cd43a74c384be4810029acf2dd1de348d732c004850b3248ba6a892451afec56fc4de0c6b05c3f4edc7b72b741e46b558 SHA512 3b6bc8b23693b1817b7f8969352bfe45f81762f86d30b9329c3c57fb1897ee5965f5759e357bbe68d21b84ac3e53e5ce80ffafccfac22d9a4a36ce104d5a2966
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.9.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.9.ebuild
new file mode 100644
index 000000000000..7a307bf1c63f
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/texlive[extra]
+ dev-python/matplotlib[latex,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/exdown[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ virtx pytest -vv
+}