summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-19 22:50:37 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-19 23:24:28 +0100
commit0eadd4800bb6d9ae5be0f9c6c3b9f1aeea01aca4 (patch)
tree3e5a9844d4bf55866ec58576e969da720ea623ff /dev-python
parentapp-admin/awscli: Bump to 1.22.10 (diff)
downloadgentoo-0eadd4800bb6d9ae5be0f9c6c3b9f1aeea01aca4.tar.gz
gentoo-0eadd4800bb6d9ae5be0f9c6c3b9f1aeea01aca4.tar.bz2
gentoo-0eadd4800bb6d9ae5be0f9c6c3b9f1aeea01aca4.zip
dev-python/pygit2: Bump to 1.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pygit2/Manifest1
-rw-r--r--dev-python/pygit2/pygit2-1.7.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pygit2/Manifest b/dev-python/pygit2/Manifest
index 0dcc19893f3f..eecec9ef872f 100644
--- a/dev-python/pygit2/Manifest
+++ b/dev-python/pygit2/Manifest
@@ -1,2 +1,3 @@
DIST pygit2-1.6.1.tar.gz 258338 BLAKE2B dc223e2a5231728c42ca7e0581483731fbab6ee090cf4aeeb27f186973b3c753fdf54c89679a88b97d834d717135f9b8f9a2adf492ed8572affa938c79d0f905 SHA512 67a78313493ba096cbae6805bda861495f33644fd180b5fb1cd99dcd226ef5a09ee85bd27d04d0697ef15503a4e902aa1384980870551f430fd9560ac949fe2f
DIST pygit2-1.7.0.tar.gz 276292 BLAKE2B 6091e2916c4986cb545f23d3a31f262666f0349661ccc48769414e888d0ede48af3a80483b4638a3a2275b74ed9b42113bdeae678f03d76caa7e796c6011b50c SHA512 3a8654036d0ab875898ce60e81bcab48bdb6d6bd63c29dc98272c71b5c82391e3186da61083fba09faf722e176fed5c592a36edb53ae0b957726e74646d25616
+DIST pygit2-1.7.1.tar.gz 281791 BLAKE2B 51f7f23752acf0abf6000f2262019db7503506267f0f5306bd53e0e15378447d2da564818c1b6efccc4759587aba6b4d7b142c760e4e2796445cd6056e949825 SHA512 a6232039b6364c7a0905aba20f7e27b43892b7067fa95fdd464438869453360ecdb885f2012cdf0eb0734c91dc79b60db894d1d0fee81922b9fb3cf920950937
diff --git a/dev-python/pygit2/pygit2-1.7.1.ebuild b/dev-python/pygit2/pygit2-1.7.1.ebuild
new file mode 100644
index 000000000000..985c2e9d1536
--- /dev/null
+++ b/dev-python/pygit2/pygit2-1.7.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libgit2"
+HOMEPAGE="https://github.com/libgit2/pygit2 https://pypi.org/project/pygit2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ =dev-libs/libgit2-1.3*:=
+ >=dev-python/cffi-1.0:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # unconditionally prevent it from using network
+ sed -i -e '/has_network/s:True:False:' test/utils.py || die
+
+ # we need to move them away to prevent pytest from forcing '..'
+ # for imports
+ mkdir hack || die
+ mv test hack/ || die
+ ln -s hack/test test || die
+}
+
+python_test() {
+ epytest hack/test
+}