summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-02-21 11:32:26 +0000
committerMarek Szuba <marecki@gentoo.org>2022-02-21 11:32:26 +0000
commit0f1e3b4c9ed83ab13a54d398368470de451bb4a0 (patch)
tree45c05293843247f8838bfaff632cdfc848f72c36 /dev-python
parentapp-crypt/yubikey-manager: add 4.0.8 (diff)
downloadgentoo-0f1e3b4c9ed83ab13a54d398368470de451bb4a0.tar.gz
gentoo-0f1e3b4c9ed83ab13a54d398368470de451bb4a0.tar.bz2
gentoo-0f1e3b4c9ed83ab13a54d398368470de451bb4a0.zip
dev-python/makefun: initial import
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/makefun/Manifest1
-rw-r--r--dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch10
-rw-r--r--dev-python/makefun/makefun-1.13.1.ebuild25
-rw-r--r--dev-python/makefun/metadata.xml13
4 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/makefun/Manifest b/dev-python/makefun/Manifest
new file mode 100644
index 000000000000..e64a9b497cde
--- /dev/null
+++ b/dev-python/makefun/Manifest
@@ -0,0 +1 @@
+DIST makefun-1.13.1.tar.gz 72170 BLAKE2B b1b5e76277e742ef51bcdf2bf6f1d1e761010d75bc3f20d7a8c079b368972b90775bd3bb23cf1787911a8d858549d72d4a2c9379675e59f359486bf1c49566e2 SHA512 ae103d3827673c4124d051e3c76d3d0d126c783ac7a1ea09de3801fd695439eaa549c297bd5c262184a3ee6fdf7b046065081fa3183642778148c2134d7bfc06
diff --git a/dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch b/dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch
new file mode 100644
index 000000000000..659717903361
--- /dev/null
+++ b/dev-python/makefun/files/makefun-1.13.1-no_pytest-runner.patch
@@ -0,0 +1,10 @@
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -27,7 +27,6 @@
+ [options]
+ setup_requires =
+ setuptools_scm
+- pytest-runner
+ install_requires =
+ funcsigs;python_version<'3.3'
+ tests_require =
diff --git a/dev-python/makefun/makefun-1.13.1.ebuild b/dev-python/makefun/makefun-1.13.1.ebuild
new file mode 100644
index 000000000000..3a44d2732c4a
--- /dev/null
+++ b/dev-python/makefun/makefun-1.13.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Small library to dynamically create Python functions"
+HOMEPAGE="https://pypi.org/project/makefun/ https://github.com/smarie/python-makefun"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.13.1-no_pytest-runner.patch
+)
+
+distutils_enable_tests pytest
diff --git a/dev-python/makefun/metadata.xml b/dev-python/makefun/metadata.xml
new file mode 100644
index 000000000000..0a2fbcffabe0
--- /dev/null
+++ b/dev-python/makefun/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">smarie/python-makefun</remote-id>
+ <remote-id type="pypi">makefun</remote-id>
+ </upstream>
+</pkgmetadata>