summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-27 07:59:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-27 09:00:16 +0200
commit11f5e847c841ea5d02fa1db1daca199b86a841db (patch)
treea41b115cf42a12308fc15395079aefa906e2f76c /dev-python
parentdev-util/source-highlight: fix tests on clang (diff)
downloadgentoo-11f5e847c841ea5d02fa1db1daca199b86a841db.tar.gz
gentoo-11f5e847c841ea5d02fa1db1daca199b86a841db.tar.bz2
gentoo-11f5e847c841ea5d02fa1db1daca199b86a841db.zip
dev-python/diskcache: Bump to 5.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/diskcache/Manifest1
-rw-r--r--dev-python/diskcache/diskcache-5.0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/diskcache/Manifest b/dev-python/diskcache/Manifest
index 5a1674b83069..47f16ab4b2c7 100644
--- a/dev-python/diskcache/Manifest
+++ b/dev-python/diskcache/Manifest
@@ -1,2 +1,3 @@
DIST diskcache-4.1.0.gh.tar.gz 658268 BLAKE2B 7712892a15e0f7b34b05c48071b4ed22f94ff4c8b6e66dff5591296d7186c686958ef3ec19994b6965319ba3e601850a1782f7ac8ed09090afda4b75ae16a12b SHA512 3871e56fa9a50942e29e200df74d7f4312d21a0f51d6be2041ce71efd3c1d0c204cc1df5ac1f92825314c742bb48bf8b0a3929cee225055903953e095701c8e3
DIST diskcache-5.0.1.gh.tar.gz 656475 BLAKE2B 1926dd40564130a24f211a1962c9a9e4ecc640ecd55d2bae5057ead787df0cc64634be8a798202702a7810612bece0d45202bb12d495da1863c8b10e645cb7fa SHA512 9e06427e8ff158fa186ed161b7e90980f1a1d866164d6018a522f80a323be981f99e4297b0d90106dfb08b5d2d0babcb5a2dafebcc194e2c282c30bcf3e0f1a1
+DIST diskcache-5.0.2.gh.tar.gz 656471 BLAKE2B d4aa7859bbefdd5aedf8bfd81ee9763890371a7667216a0d4a1728d5eacb643749adfb9f7324745f67c145ed6d61f50c449d1cc20ac9b77386aacad639fe1856 SHA512 79fc94be90517a55cd94f67b5c33279925beaf6cc38027c26603b67527b49976c3aaa80368db2671cce7deb4e933aacb8f89ed85dafe3cdc2f99862b2b49471c
diff --git a/dev-python/diskcache/diskcache-5.0.2.ebuild b/dev-python/diskcache/diskcache-5.0.2.ebuild
new file mode 100644
index 000000000000..c07ed748a131
--- /dev/null
+++ b/dev-python/diskcache/diskcache-5.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="http://www.grantjenks.com/docs/diskcache/
+ https://github.com/grantjenks/python-diskcache/"
+DESCRIPTION="Disk and file backed cache"
+SRC_URI="
+ https://github.com/grantjenks/python-diskcache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+S=${WORKDIR}/python-diskcache-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove dep on pytest-xdist
+ sed -i -e '/-n auto/d' tox.ini || die
+
+ distutils-r1_src_prepare
+}