summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-22 08:14:55 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-22 09:06:59 +0100
commit13137779d1add98c54cb1690bb1aecb48a97b1aa (patch)
tree2b8b100f5828880ece6a34692630649023e45cfc /dev-python
parentdev-python/boto3: Bump to 1.16.41 (diff)
downloadgentoo-13137779d1add98c54cb1690bb1aecb48a97b1aa.tar.gz
gentoo-13137779d1add98c54cb1690bb1aecb48a97b1aa.tar.bz2
gentoo-13137779d1add98c54cb1690bb1aecb48a97b1aa.zip
dev-python/setuptools: Bump to 51.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-51.1.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index dd980078d013..1d5112f1c534 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -1,3 +1,4 @@
DIST setuptools-46.4.0.zip 865912 BLAKE2B 452d36132f5648c79c7e1616a93ff6a39ab2f64b2864ee397b4f57e7f72c47d418ff274f5decd35b0591b09800ad2a7cbd71c283550bd0e60a4d85744a57d4ec SHA512 31e58fd1d682089a45d23aa07c3c2c4c952ca016fa4c3416b2cba979d8b57369f80baef98ce857912e506e87d6cb456497a1ce1c75a0cdf1ee25d4e753b58726
DIST setuptools-50.3.0.zip 2169216 BLAKE2B 029ea0159de270af0078a4661c696b93681b33dcc475640c7626f5a40bf1bb4759e5915948696c03b76dca10bdc4e790e2e9ef9628f41abca9a6aa48adcb72f6 SHA512 f67a2b7d639e03bf8b3815133e128902a559baf689afdd5893844ddc7c83505d727a6bb30ced1f78c4d2719dd405d2f4c527576bfa14dd9cb50c8ec4a479683e
DIST setuptools-51.0.0.zip 2059134 BLAKE2B 449e87e413490181136ffa80a109e68b086fd0b1b56b2391e8cc612fb4c9cd4bb89acf05b464a5fa86c3984d3f22bc103dc9a21a2948598b7a17f770c4037008 SHA512 ec8c8a43ef176b5a4029f42c900690c1b9cb304efeb2cf8d36f3f2cb4343af4c1b1770f83ffb0e80ef237f58e6eeb233a97d6b3b8c6c6a2557bc4f14ccff9e90
+DIST setuptools-51.1.0.tar.gz 2050951 BLAKE2B 58890bf458ffab84f93e68393a092c2b2eeaf28e9e443c9a3cf50fb4bbb371bfe28032d08c5ce92fc0b28ad3f9b718f02542f948560b2a8a57af1ada9e77a949 SHA512 914f0d7692f519b658a55e1c7d96b93a45f34c1682c564c6232cd3771db15c91cfee7118ed61f1ae4655a1afe34c9a9c37f293eb6408eeeeeae9eaa6f3760324
diff --git a/dev-python/setuptools/setuptools-51.1.0.ebuild b/dev-python/setuptools/setuptools-51.1.0.ebuild
new file mode 100644
index 000000000000..a97d4b15eeab
--- /dev/null
+++ b/dev-python/setuptools/setuptools-51.1.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst )
+
+python_prepare_all() {
+ # disable tests requiring a network connection
+ rm setuptools/tests/test_packageindex.py || die
+
+ # don't run integration tests
+ rm setuptools/tests/test_integration.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing --via-root
+ local deselect=(
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ )
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv setuptools ${deselect[@]/#/--deselect } ||
+ die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}