summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-09 19:36:02 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-09 19:48:46 +0100
commit13e9b5d713423aa7abf36913ee8199fdc55d9e6d (patch)
tree2f2e4af061a9162aff8deafd785a2b8af2ff26f3 /dev-python
parentdev-util/pkgcheck: Bump to 0.8.2 (diff)
downloadgentoo-13e9b5d713423aa7abf36913ee8199fdc55d9e6d.tar.gz
gentoo-13e9b5d713423aa7abf36913ee8199fdc55d9e6d.tar.bz2
gentoo-13e9b5d713423aa7abf36913ee8199fdc55d9e6d.zip
dev-python/tqdm: Bump to 4.56.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/tqdm-4.56.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index d6828aeb1c46..58f5f4893a76 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -2,3 +2,4 @@ DIST tqdm-4.55.0.tar.gz 161594 BLAKE2B 890bbb47db356678be2c3edd893d70b085f5bc8fe
DIST tqdm-4.55.1.tar.gz 161638 BLAKE2B 0149269f1ea854589647deb4ddd7415748924942ecc03d5fd6231470e5df959c1b8034d4d8416d83aa0a43ad1fafed15789f7ebaac12e5d525a7fe0bee88752a SHA512 82a6d3d8e10d4c46e40e03e557febe9f7cac3cc01c01c9e29b20cf8f2adcc7370829fe5d4497ff0edb506bf38b9ec14de86377d1bbd9b8b9e57687d951ae683f
DIST tqdm-4.55.2.tar.gz 162632 BLAKE2B 02e49f442c8d5ad3799de143dd8a188796293253e836c24d04e75aa45f7cbeecb967f1503467ca7486dfd412538da6f7a3aa4c674e16f0da3954f44347c5a498 SHA512 f61f28f2b8f7c4d848e31a3d791822a0433573b36aa900d055e1919b555b84ee36d988c6f51d6951355e70821f4d24bee72bdd4472262ea55ea012ff0556b0df
DIST tqdm-4.56.0.tar.gz 166848 BLAKE2B d2239ff7efd9c91b7101357b6c7d352c42c49c41c34209092fdfe420e090458581aed61f2ddff09d1c64539eed0d83eb240e6b467b82193016cf13bac94f3313 SHA512 c65eb167063c4b6a0931a6f19fb2e4d88eb92fe3f3118c0247cd0e148220523097c4419289428d2a4c22cc187011d78cba32fc080eb2cbe352f873e29646094e
+DIST tqdm-4.56.1.tar.gz 166899 BLAKE2B 11c40049ee2d3ce890a6a443432fd2834b177ea4d19549c179dcc9da6bcd71093b54a5f2a7027ab40e9c5c7bf48581c7fe4cd4ad819a3d60a8e3c7c5537fd357 SHA512 4b940bbf2fdd1093e1e0c50f17de7231dd58b0f04d9a8a97df4835f23e46b7b58f68e1ad96f77b191cae49e80498fd31ae67ff4fb4db821d90ec85bf83d48043
diff --git a/dev-python/tqdm/tqdm-4.56.1.ebuild b/dev-python/tqdm/tqdm-4.56.1.ebuild
new file mode 100644
index 000000000000..0bf4e4570b83
--- /dev/null
+++ b/dev-python/tqdm/tqdm-4.56.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tqdm/tqdm"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="Add a progress meter to your loops in a second"
+HOMEPAGE="https://github.com/tqdm/tqdm"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Skip unpredictable performance tests
+ pytest -vv --ignore 'tests/tests_perf.py' ||
+ die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
+ rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}