summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-27 08:55:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-27 10:29:08 +0200
commit15a32d6778ce7a789104663e9bf1555974eb6693 (patch)
tree5231ff79aba29dfa1693cc9302d732b5b6c9e524 /dev-python
parentdev-python/botocore: Bump to 1.22.4 (diff)
downloadgentoo-15a32d6778ce7a789104663e9bf1555974eb6693.tar.gz
gentoo-15a32d6778ce7a789104663e9bf1555974eb6693.tar.bz2
gentoo-15a32d6778ce7a789104663e9bf1555974eb6693.zip
dev-python/boto3: Bump to 1.19.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.19.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index b28f32092565..c28ca76e0d68 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,3 +9,4 @@ DIST boto3-1.19.0.tar.gz 430753 BLAKE2B 24b18d5ac312cac54952e6abc0da80e09c7618ba
DIST boto3-1.19.1.tar.gz 430897 BLAKE2B fad3df04ce3dd909684dae90d7b83f4c06bb33fd488e6916179bb886f2753890e82b53c38fcceb3a3342be0681f112bb836f65e293b762431abd2ab1b2b71061 SHA512 cefa3cd811559cba4bd8b39b5d9ed1b2f45d4cce45a537bcde32b808872d8d48828562f6226a128c0befc842777fb07b1ad81b4abbe7b45113b748d4086bb289
DIST boto3-1.19.2.tar.gz 431304 BLAKE2B 9fe4bea7087488b5bc0ea0583fd774ed5b968dd3f2c948536d4063c246ffd74a1bd988046daeb7b8145f46b8f7e1ce6ffe93f8e18f624f65558e1dff1988edf0 SHA512 e23835e1f5c7ab8c3776d6632725bdf9eb4c72b34df6426967833bd799697326f88da2dcd12d4f7232ffba9cbcdf180fccdacf7f7a713c670584fc36182f3393
DIST boto3-1.19.3.tar.gz 432019 BLAKE2B aed6e6001a421a3c7a885aabafc233a0291684eb23eb15cd1bfa27e961dae8be1964aa2cb803f1a139ea423cd756d95ba015e55287dd3c2838c74bf69c0d2acc SHA512 8a7dc38ba705e73d1d5f2bc7aac79efa9a56dfe6c60c7be40458670368e131800e1d48a6d97f1b84ee18036ea69f397441529b3a0410a2ca8c2d9b95d3085827
+DIST boto3-1.19.4.tar.gz 432282 BLAKE2B b0a96b4eb5d8a7a0e2881040cee848cb23d14caf649078566f0404d6a354da52d6bd97c2adec3e58d1e1a9dd239fe4ac828c0f92be7c36019c55fc26fb97d210 SHA512 6c8fb967492e9990851e4de3feb76618893464c9e144280741c7d5d41655e3a90ce2629c64c1822847816791aef256416474e78b85565e83041a8b2630bf1421
diff --git a/dev-python/boto3/boto3-1.19.4.ebuild b/dev-python/boto3/boto3-1.19.4.ebuild
new file mode 100644
index 000000000000..450c87d9f8b7
--- /dev/null
+++ b/dev-python/boto3/boto3-1.19.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}