summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Bakhtiari <dev@mtbk.me>2021-05-11 06:21:22 +0200
committerSam James <sam@gentoo.org>2021-06-01 00:27:54 +0000
commit1666f2f5c8d1aa98987ad49120af256a12f0e124 (patch)
tree1a148a13a3a3582a2a8824520649128dbc1fb4e1 /dev-python
parentmedia-sound/lollypop: Version bump 1.4.18 (diff)
downloadgentoo-1666f2f5c8d1aa98987ad49120af256a12f0e124.tar.gz
gentoo-1666f2f5c8d1aa98987ad49120af256a12f0e124.tar.bz2
gentoo-1666f2f5c8d1aa98987ad49120af256a12f0e124.zip
dev-python/requests-credssp: python 3.9 support
Closes: https://bugs.gentoo.org/788670 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matthew Bakhtiari <dev@mtbk.me> Closes: https://github.com/gentoo/gentoo/pull/20767 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch50
-rw-r--r--dev-python/requests-credssp/requests-credssp-1.2.0.ebuild8
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch b/dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch
new file mode 100644
index 000000000000..47591ab94edb
--- /dev/null
+++ b/dev-python/requests-credssp/files/requests-credssp-1.2.0-python-3.9.patch
@@ -0,0 +1,50 @@
+From b3583f2e959600ea27a2b8577c172c5695ec7f2c Mon Sep 17 00:00:00 2001
+From: Matthew <matthewabtin@protonmail.com>
+Date: Mon, 10 May 2021 10:36:23 +0000
+Subject: [PATCH] Python 3.9 support (#22)
+
+* Python 3.9 support
+
+* Add 3.9 to pipelines
+---
+ azure-pipelines.yml | 8 ++++++++
+ setup.py | 1 +
+ 2 files changed, 9 insertions(+)
+
+diff --git a/azure-pipelines.yml b/azure-pipelines.yml
+index a60bd62..1f0cbde 100644
+--- a/azure-pipelines.yml
++++ b/azure-pipelines.yml
+@@ -38,6 +38,8 @@ stages:
+ python.version: 3.7
+ Python38:
+ python.version: 3.8
++ Python39:
++ python.version: 3.9
+
+ steps:
+ - task: UsePythonVersion@0
+@@ -119,6 +121,12 @@ stages:
+ Python38-x64:
+ python.version: 3.8
+ python.arch: x64
++ Python39-x86:
++ python.version: 3.9
++ python.arch: x86
++ Python39-x64:
++ python.version: 3.9
++ python.arch: x64
+
+ steps:
+ - task: UsePythonVersion@0
+diff --git a/setup.py b/setup.py
+index ee5268f..49af47b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -53,5 +53,6 @@ def abs_path(rel_path):
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
++ 'Programming Language :: Python :: 3.9',
+ ],
+ )
diff --git a/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild b/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
index 568e4c292497..a06c1ac3a655 100644
--- a/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
+++ b/dev-python/requests-credssp/requests-credssp-1.2.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit distutils-r1
DESCRIPTION="HTTPS CredSSP authentication with the requests library"
@@ -23,3 +23,7 @@ RDEPEND="dev-python/cryptography[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.0-python-3.9.patch"
+)