summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2019-03-28 00:52:28 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-03-28 00:56:04 +0100
commit16f6f818b57fc67e0995b5ce09e27a9f75e70ba3 (patch)
treed97a02e4b8bebaf62e83a44b6ba9f4e55d3b2467 /dev-python
parentapp-editors/neovim: version bump. (diff)
downloadgentoo-16f6f818b57fc67e0995b5ce09e27a9f75e70ba3.tar.gz
gentoo-16f6f818b57fc67e0995b5ce09e27a9f75e70ba3.tar.bz2
gentoo-16f6f818b57fc67e0995b5ce09e27a9f75e70ba3.zip
dev-python/neovim-python-client: update DEPEND/RDEPEND.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild32
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.3.1.ebuild4
-rw-r--r--dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild32
3 files changed, 66 insertions, 2 deletions
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..5e5ba983bf68
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.3.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/pynvim"
+SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
+
+RDEPEND="
+ ${DEPEND}
+ >=app-editors/neovim-0.2.1"
+
+S="${WORKDIR}/pynvim-${PV}"
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -i '/^msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.1.ebuild
index 751a436d4fda..9c534e297e69 100644
--- a/dev-python/neovim-python-client/neovim-python-client-0.3.1.ebuild
+++ b/dev-python/neovim-python-client/neovim-python-client-0.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -21,7 +21,7 @@ DEPEND="
RDEPEND="
${DEPEND}
- >=app-editors/neovim-0.2.1"
+ app-editors/neovim"
S="${WORKDIR}/pynvim-${PV}"
diff --git a/dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild b/dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild
new file mode 100644
index 000000000000..52c62c1ef2dd
--- /dev/null
+++ b/dev-python/neovim-python-client/neovim-python-client-0.3.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for Neovim"
+HOMEPAGE="https://github.com/neovim/pynvim"
+SRC_URI="https://github.com/neovim/pynvim/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ virtual/python-greenlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)"
+
+RDEPEND="
+ ${DEPEND}
+ app-editors/neovim"
+
+S="${WORKDIR}/pynvim-${PV}"
+
+python_prepare_all() {
+ # allow useage of renamed msgpack
+ sed -i '/^msgpack/d' setup.py || die
+ distutils-r1_python_prepare_all
+}