summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-09-28 18:26:35 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-09-28 19:03:18 +0200
commit171cae7b40eaa94c32dbbf66384283eae1f0d3d8 (patch)
tree3845117f2e60af89ad6e1bc3a20afdb24817f79c /dev-python
parentdev-python/humanfriendly: bump to 8.2, fix deps, support PyPy3+Py3.9 (diff)
downloadgentoo-171cae7b40eaa94c32dbbf66384283eae1f0d3d8.tar.gz
gentoo-171cae7b40eaa94c32dbbf66384283eae1f0d3d8.tar.bz2
gentoo-171cae7b40eaa94c32dbbf66384283eae1f0d3d8.zip
dev-python/capturer: bump to 3.0, add PyPy3+Py3.9 and doc
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/capturer/Manifest1
-rw-r--r--dev-python/capturer/capturer-3.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/capturer/Manifest b/dev-python/capturer/Manifest
index a875a3e6b22c..abfb134621bd 100644
--- a/dev-python/capturer/Manifest
+++ b/dev-python/capturer/Manifest
@@ -1 +1,2 @@
DIST capturer-2.4.tar.gz 16963 BLAKE2B 329e388059a033993cf2ac3744a8df273beea0239f3696d19aece57767b0b5cd3397fa095f860c4f00ef24e8cd6bf2e58aab4158a86cf8c0c09c89d2065de0da SHA512 d85614b0424ab8817df9475ac0d230d7151289a3353a3c043a7fa89dac0528265a4dee535cac9ad0a3c2fbb0cac18afa69cd0a405b1becab55f9a6be13df0c46
+DIST capturer-3.0.tar.gz 18146 BLAKE2B 345313fa9e58c4e0121c795bd99606f99e46459215ed239da56586da8f8ffab35d97f0bf655258abe9cc45d4abaf7cb0ad2e76054d8c1781be2531ca01b04381 SHA512 3c83c0eade27380304347bdc93df392b2cb84c084e50693993dcca5fd572b8f92d31de43b4a2ddd0a0e8c7eb097629127e86a4860918c507d13b0e2979a04098
diff --git a/dev-python/capturer/capturer-3.0.ebuild b/dev-python/capturer/capturer-3.0.ebuild
new file mode 100644
index 000000000000..871d5abc7b60
--- /dev/null
+++ b/dev-python/capturer/capturer-3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Easily capture stdout/stderr of the current process and subprocesses"
+HOMEPAGE="https://capturer.readthedocs.io/en/latest/
+ https://pypi.org/project/capturer/
+ https://github.com/xolox/python-capturer"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/humanfriendly[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv ${PN}/tests.py || die "Tests fail with ${EPYTHON}"
+}