summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-16 14:44:51 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-16 14:53:14 +0100
commit17a59885500311537abba7b56e84107cc724052e (patch)
tree5bf07a16a223a9c10378ba88a6d2cc25032df339 /dev-python
parentdev-python/iso8601: Enable py3.8 (diff)
downloadgentoo-17a59885500311537abba7b56e84107cc724052e.tar.gz
gentoo-17a59885500311537abba7b56e84107cc724052e.tar.bz2
gentoo-17a59885500311537abba7b56e84107cc724052e.zip
dev-python/pytz: Bump to 2019.3, py3.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/pytz-2019.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index 9ff364c5c6b6..fd7b1cbc412b 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -2,3 +2,4 @@ DIST pytz-2016.3.tar.bz2 170906 BLAKE2B ae1c5336919cd60d643afcaec8889793092da1b1
DIST pytz-2017.2.zip 502168 BLAKE2B a1e02967700d0624d2c48bcedde52b772471aefcb1dc173fc067045a69d808dc8208ef300d67c683b0d49a0b19b6c22f9d5512a6a10559457e19a508e4b40ace SHA512 d67d64a64b4c21e0bd41da56020fc7b016aec9da7f3243f79b65704119f70b8a9cd4f5f905631b6761e06ecef93830e5e479e16c7b1611ac70e0cd2b39d5b916
DIST pytz-2018.4.tar.gz 308066 BLAKE2B 665cebc5b535aafc92a1858b718d22818810534d8680a82ef3a0b66e6092f24226c36eb74feb690e25578b4d6ab8288cc4825eb5fb793345e11b0e71c6041868 SHA512 8a15e64d0d1a4b75c1e92360b22c06a41a692fe54fc8bfcff8cfa671095232d87f7929240441cd4d46826cd13f21d348125509c899be5a0b19bc7a77fdcb43c1
DIST pytz-2018.9.tar.gz 310705 BLAKE2B 38e4f403e299ca3c24e5cde66bc02ebb861abfb7be06bcb0556fa75f426a2d3e1ac42466ea2296ddf52d3ed0e0f6f2478733d9877d2b891b5f4787cd1e792d91 SHA512 c3dabe61d04539245761a5c4e3bfb614df1c3b8ccc2ffa1cf320c5ad642242c29b3321fe7855d32a2ae55c739acbbe8c0e1813df5b3c757b8f56fff910fee159
+DIST pytz-2019.3.tar.gz 312286 BLAKE2B 8a81caf3ead284a66404fadeca4f17a603a4f0ab2404f9b73b2b06a209d0094a25549065aa14d254239d6d842804c6924bc7658a876517b170f535be71868ead SHA512 b925b59d197e7007dae8098d35518a470e4b7588d9114f51e4d8816813243a9f816f662055f690bedf56b86cc9ece06428ed8c55e5b3ed676ba0f504f7cb43af
diff --git a/dev-python/pytz/pytz-2019.3.ebuild b/dev-python/pytz/pytz-2019.3.ebuild
new file mode 100644
index 000000000000..2b38219a923d
--- /dev/null
+++ b/dev-python/pytz/pytz-2019.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="https://pythonhosted.org/pytz/ https://pypi.org/project/pytz/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE=""
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ || ( >=sys-libs/timezone-data-2017a sys-libs/glibc[vanilla] )"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+PATCHES=(
+ # Use timezone-data zoneinfo.
+ "${FILESDIR}"/2018.4-zoneinfo.patch
+ # ...and do not install a copy of it.
+ "${FILESDIR}"/${PN}-2018.4-zoneinfo-noinstall.patch
+)
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v || die "Tests fail with ${EPYTHON}"
+}