summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2020-07-17 10:43:59 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-07-19 13:43:24 +0300
commit1a193d349c56afe52b946352e1d8f64bc83c24e5 (patch)
tree82133634f7c322ba9a22312913dfa529c48373cc /dev-python
parentdev-python/doit-py: fix #732192 (diff)
downloadgentoo-1a193d349c56afe52b946352e1d8f64bc83c24e5.tar.gz
gentoo-1a193d349c56afe52b946352e1d8f64bc83c24e5.tar.bz2
gentoo-1a193d349c56afe52b946352e1d8f64bc83c24e5.zip
dev-python/quantities: new package
This package is an optional rdep of dev-python/pylatex Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/quantities/Manifest1
-rw-r--r--dev-python/quantities/metadata.xml17
-rw-r--r--dev-python/quantities/quantities-0.12.4.ebuild36
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/quantities/Manifest b/dev-python/quantities/Manifest
new file mode 100644
index 000000000000..fa90e3a5b653
--- /dev/null
+++ b/dev-python/quantities/Manifest
@@ -0,0 +1 @@
+DIST python-quantities-0.12.4.tar.gz 104093 BLAKE2B 84587726ef3c2f4c7dce4ea538363aecc42aa88c31d2990f834f2de9540b52d6ca0c437c1876a4c2dd5512b4be3af95cc64a1294ea60555ed1b51819f7f46125 SHA512 b5d181880d0789e6fbd55837c5ce65b677764a718be4550f1f553131e171caa59f8fc84d67e69563a293cda01e7b0678074fb311b3766f0013e658a9fa00471f
diff --git a/dev-python/quantities/metadata.xml b/dev-python/quantities/metadata.xml
new file mode 100644
index 000000000000..7ffdf7f0ad4e
--- /dev/null
+++ b/dev-python/quantities/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ddenoncin@gmail.com</email>
+ <name>David Denoncin</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">python-quantities/python-quantities</remote-id>
+ <remote-id type="pypi">quantities</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/quantities/quantities-0.12.4.ebuild b/dev-python/quantities/quantities-0.12.4.ebuild
new file mode 100644
index 000000000000..41a8e27b48b7
--- /dev/null
+++ b/dev-python/quantities/quantities-0.12.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="python-quantities"
+MY_PV="$(ver_cut 1-3)"
+MY_P="${MY_PN}-${PV}"
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Support for physical quantities with units, based on numpy"
+HOMEPAGE="https://github.com/python-quantities/python-quantities"
+SRC_URI="https://github.com/python-quantities/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${MY_PN}-${MY_PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/numpy[$PYTHON_USEDEP]
+"
+distutils_enable_tests unittest
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # Unexpected success
+ sed -i -e 's:test_fix:_&:' \
+ quantities/tests/test_umath.py || die
+
+ distutils-r1_python_prepare_all
+}