summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-06-11 16:53:53 +0100
committerMarek Szuba <marecki@gentoo.org>2021-06-11 17:32:45 +0100
commit1aa3ae11dc9979b2afeaae6c2b71a3dc760275eb (patch)
treeae8b6a6cc026e6faf7009183501f3a3f86a790b3 /dev-python
parentapp-emulation/docker: stabilize 20.10.7 on amd64 (diff)
downloadgentoo-1aa3ae11dc9979b2afeaae6c2b71a3dc760275eb.tar.gz
gentoo-1aa3ae11dc9979b2afeaae6c2b71a3dc760275eb.tar.bz2
gentoo-1aa3ae11dc9979b2afeaae6c2b71a3dc760275eb.zip
dev-python/pywinrm: initial import
Builds, tests and installs fine for both 3.8 and 3.9 (3.10 support currently omitted due to dependencies), both with and without USE=kerberos - which also enables CredSSP support, for consistency with net-misc/rdesktop. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pywinrm/Manifest1
-rw-r--r--dev-python/pywinrm/files/pywinrm-0.4.2_test-installation.patch11
-rw-r--r--dev-python/pywinrm/metadata.xml13
-rw-r--r--dev-python/pywinrm/pywinrm-0.4.2.ebuild33
4 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pywinrm/Manifest b/dev-python/pywinrm/Manifest
new file mode 100644
index 000000000000..d59d8d398cdc
--- /dev/null
+++ b/dev-python/pywinrm/Manifest
@@ -0,0 +1 @@
+DIST pywinrm-0.4.2.tar.gz 37842 BLAKE2B cf9eb683b77f9a2cc2da9343ebcbbd27404024aea23784721fbea0bce4f8a2359c3647e81bb5fce7f9317bcd8d84cef2c5ec76b17d15153348e66897a6fe1319 SHA512 c5ff02606d6c887ef199cf814d931575728947bbbbff3c2ae7e52bed355408df06ea9351a4ae0b47a947a05ca3476054e501b3abcfca5a36643ef4cd6855a0e4
diff --git a/dev-python/pywinrm/files/pywinrm-0.4.2_test-installation.patch b/dev-python/pywinrm/files/pywinrm-0.4.2_test-installation.patch
new file mode 100644
index 000000000000..d7f38f7163dd
--- /dev/null
+++ b/dev-python/pywinrm/files/pywinrm-0.4.2_test-installation.patch
@@ -0,0 +1,11 @@
+--- a/setup.py
++++ b/setup.py
+@@ -21,7 +21,7 @@
+ author_email='alexey.diyan@gmail.com',
+ url='http://github.com/diyan/pywinrm/',
+ license='MIT license',
+- packages=find_packages(),
++ packages=find_packages(exclude=('winrm.tests',)),
+ package_data={'winrm.tests': ['*.ps1']},
+ install_requires=['xmltodict', 'requests>=2.9.1', 'requests_ntlm>=0.3.0', 'six'],
+ extras_require={
diff --git a/dev-python/pywinrm/metadata.xml b/dev-python/pywinrm/metadata.xml
new file mode 100644
index 000000000000..552844c50551
--- /dev/null
+++ b/dev-python/pywinrm/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">diyan/pywinrm</remote-id>
+ <remote-id type="pypi">pywinrm</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pywinrm/pywinrm-0.4.2.ebuild b/dev-python/pywinrm/pywinrm-0.4.2.ebuild
new file mode 100644
index 000000000000..b319eeabba15
--- /dev/null
+++ b/dev-python/pywinrm/pywinrm-0.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for the Windows Remote Management (WinRM) service"
+HOMEPAGE="https://github.com/diyan/pywinrm/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="kerberos"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-ntlm[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ kerberos? (
+ <dev-python/pykerberos-2.0.0[${PYTHON_USEDEP}]
+ dev-python/requests-credssp[${PYTHON_USEDEP}]
+ )"
+BDEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.2_test-installation.patch
+)
+
+distutils_enable_tests pytest