summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-05 09:35:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-05 11:41:05 +0200
commit1b27e89939649b695a92e2dfe90ea1f39ab9c339 (patch)
tree7e2a87362456e266edf6530b68baddb29675245e /dev-python
parentapp-admin/awscli: Bump to 1.25.87 (diff)
downloadgentoo-1b27e89939649b695a92e2dfe90ea1f39ab9c339.tar.gz
gentoo-1b27e89939649b695a92e2dfe90ea1f39ab9c339.tar.bz2
gentoo-1b27e89939649b695a92e2dfe90ea1f39ab9c339.zip
dev-python/openapi-core: Bump to 0.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/openapi-core/Manifest1
-rw-r--r--dev-python/openapi-core/openapi-core-0.16.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/openapi-core/Manifest b/dev-python/openapi-core/Manifest
index 630d6d32635d..81d98c0d50d3 100644
--- a/dev-python/openapi-core/Manifest
+++ b/dev-python/openapi-core/Manifest
@@ -1,3 +1,4 @@
DIST openapi-core-0.14.2.gh.tar.gz 57519 BLAKE2B 06dfd284612ca11a271f075444db9b859ca5416e31594680d6b32abec1fe917105f213209d1bfcb9664b265ea3d62839579134e8e104754075cd692d1ba7a99a SHA512 19a2508d56053214993abed7d173d17b55a80dac6421681d7c64082f910bf9cb03c99d4006a2cd883d51d54f11a18f90188f141a78b9d69a9a031c284a14f8f1
DIST openapi-core-0.14.5.gh.tar.gz 57645 BLAKE2B c5c9c308b93a37e32708677cc7c7a2ccb9ec3f018390e56a251224b6b8776943ccd0ddfb560cdc3f1182cb32a9b2817878a0d4dda3906c179db9841853caf7ac SHA512 69d9fb2cc21dfdb939beae45b1c681faf9f8e3366b36e5907b00be65ac669ec40e3ae3fe910fb2c4f6c70d1412e6a67e4e4e47e3cf2c424716da4c813223295e
DIST openapi-core-0.15.0.gh.tar.gz 73274 BLAKE2B 8bae95a3a70438702d6a49c06954dba610766b945076357cc32382b59efbbf2d839a282b41b3d96f75b25e8864c0b9f9bfec1eecd8056e205bda5d62fbc6abc4 SHA512 3e9327fdf7d8b84d29627bfcb9a7c7e471ddf8cb06c5b2ffd3518fadcb872738cdfc5365558c51b8e0526bfbe5a841b9bc9598d630c6c6ddf141dc9c6681c3d6
+DIST openapi-core-0.16.0.gh.tar.gz 79041 BLAKE2B 93745787d39dc2e77e6b268792548069e7637ea7acbf4975224d837b87f301ea5ae36c07aec5b8f44b6e7a5480aab744e9601663f080d63f27b8a49aeb9cd7f5 SHA512 70ed773926c16df9d085e7ce104a0a99ccc52e8e0ba395ead1cf5e9cba1e43723bb7a744cd2b9c27e3a8a48319f8265dc5745c20cc23e825fa28ed3b2fcd3e25
diff --git a/dev-python/openapi-core/openapi-core-0.16.0.ebuild b/dev-python/openapi-core/openapi-core-0.16.0.ebuild
new file mode 100644
index 000000000000..14f8bef1d51b
--- /dev/null
+++ b/dev-python/openapi-core/openapi-core-0.16.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Client-side and server-side support for the OpenAPI Specification v3"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-core/
+ https://pypi.org/project/openapi-core/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-core/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pathable-0.4.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-spec-0.1.1[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/parse[${PYTHON_USEDEP}]
+ <dev-python/openapi-schema-validator-0.4[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.3[${PYTHON_USEDEP}]
+ <dev-python/openapi-spec-validator-0.6[${PYTHON_USEDEP}]
+ >=dev-python/openapi-spec-validator-0.5[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.21.0[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+ dev-python/webob[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # falcon is not packaged
+ tests/integration/contrib/falcon
+
+ # TODO: these tests fail to collect
+ tests/integration/validation/test_security_override.py
+ tests/integration/validation/test_read_only_write_only.py
+
+ # unhappy about modern django
+ tests/integration/contrib/django/test_django_project.py
+ tests/unit/contrib/django/test_django.py
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}