summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 09:23:51 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 10:31:52 +0200
commit1bddf69e59b7f82df2bff2f27ab9a9bfb8006866 (patch)
treeae5f20f619b27cc3d76018fe9efb10465389f328 /dev-python
parentdev-python/d2to1: Version Bump (diff)
downloadgentoo-1bddf69e59b7f82df2bff2f27ab9a9bfb8006866.tar.gz
gentoo-1bddf69e59b7f82df2bff2f27ab9a9bfb8006866.tar.bz2
gentoo-1bddf69e59b7f82df2bff2f27ab9a9bfb8006866.zip
dev-python/stsci-distutils: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stsci-distutils/metadata.xml12
-rw-r--r--dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild13
2 files changed, 14 insertions, 11 deletions
diff --git a/dev-python/stsci-distutils/metadata.xml b/dev-python/stsci-distutils/metadata.xml
index 075a4ef1271d..9d1830ea8ac0 100644
--- a/dev-python/stsci-distutils/metadata.xml
+++ b/dev-python/stsci-distutils/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<herd>sci-astronomy</herd>
-<longdescription>
+ <herd>python</herd>
+ <herd>sci-astronomy</herd>
+ <longdescription>
This package contains utilities used to package some of STScI's Python
projects; specifically those projects that comprise stsci_python and
Astrolib.
@@ -11,7 +11,7 @@
distutils2/packaging and/or d2to1, and a customized easy_install command
meant for use with distribute.
</longdescription>
-<upstream>
- <remote-id type="pypi">stsci.distutils</remote-id>
-</upstream>
+ <upstream>
+ <remote-id type="pypi">stsci.distutils</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild b/dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild
index e984e71f8ab0..f4b369bb71c0 100644
--- a/dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild
+++ b/dev-python/stsci-distutils/stsci-distutils-0.3.7.ebuild
@@ -4,12 +4,13 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-MY_PN=${PN/-/.}
-MY_P=${MY_PN}-${PV}
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy )
inherit distutils-r1
+MY_PN=${PN/-/.}
+MY_P=${MY_PN}-${PV}
+
DESCRIPTION="Utilities used to package some of STScI's Python projects"
HOMEPAGE="http://www.stsci.edu/resources/software_hardware/stsci_python"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
@@ -19,8 +20,10 @@ SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+DEPEND="
dev-python/d2to1[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
S="${WORKDIR}/${MY_P}"