summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-31 08:53:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-10-31 09:33:37 +0100
commit1ca91d689314e981ed6743ef6c7a1bda9ec72339 (patch)
tree7ec3d60ecba849fa06fcf938a51f6ceb473b3672 /dev-python
parentdev-python/botocore: Bump to 1.19.9 (diff)
downloadgentoo-1ca91d689314e981ed6743ef6c7a1bda9ec72339.tar.gz
gentoo-1ca91d689314e981ed6743ef6c7a1bda9ec72339.tar.bz2
gentoo-1ca91d689314e981ed6743ef6c7a1bda9ec72339.zip
dev-python/boto3: Bump to 1.16.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.16.9.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 746f97b8376d..f4dba1cb42d8 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -10,3 +10,4 @@ DIST boto3-1.16.5.tar.gz 337358 BLAKE2B 7bfe739ca601192adfbee3e13a6ac5490c547ba0
DIST boto3-1.16.6.tar.gz 337356 BLAKE2B bf77f8ca696219b2689b0eaa872c114d0df77d2a19f9bdd17fb35aed84f627a4cb6f7cabbf86ce369d43b34e6f2c005f6fb261be6f0c6fd911abc636b3bcc803 SHA512 2f1d4eae6c31de2fe37aac455f35c18ce498f3d49d123f240c0ef28f2e985b61f8106ada32fafe15cdb5f6f5e74641384715a652d795936b05bcc568dccb7fef
DIST boto3-1.16.7.tar.gz 337492 BLAKE2B 5b18b5bf7470566e79503692bf9703a283e9b8ec076aac8a0fa0bfcd5c84d927be5dd16d22e2e8497fafc75ca5b0c374ab4a8f02c4d2f6f8bb92db593528a02c SHA512 7e4df78abd055d7c3f1ea4ba03a12de161b08689a6f72a4c5469cac5bd7edc1736655c43e1269b1717a7cc976b2286fa75e24c0396e22583810033402145e19f
DIST boto3-1.16.8.tar.gz 337646 BLAKE2B 2a80dec73fde994d9b9174d45c4b7b4920e2d5e54dbd619502c796a3c76de23b56f9e4e41a6338a2b87445965aa969d8282a03106030f3be74adb80b311af8cb SHA512 a8289719ac61fd07eb1b275cfae35f4903d1147618135c89bb1c9ec505e79b18bf7d0f29cf0284c8849cebee22760085bddf8fba12467a9367f149be8e3192d1
+DIST boto3-1.16.9.tar.gz 337905 BLAKE2B ed01e28fd7e62e5e5028307c93f92004bfbecffa77bc2ba1d6574b92ec2c515d910eb5107ac5ee03e0aca909f97f379aa65b5f839c8067634fa69266c58de33f SHA512 7343b8432788ef981819f91fe2ba27c4ec3947d01ff55914f7c89607250ecf60db2da8d25c8a2c7001ef546a9abed4cb744c5937ca09497aa1a983049648bd5e
diff --git a/dev-python/boto3/boto3-1.16.9.ebuild b/dev-python/boto3/boto3-1.16.9.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.16.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}