summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2019-12-31 14:30:23 +0100
committerLouis Sautier <sbraz@gentoo.org>2019-12-31 15:14:37 +0100
commit1db32248868329eea9b57247b9eb2e3ebc383b37 (patch)
treee1b969ee7a58f012838b093c13523c61bb0603a9 /dev-python
parentdev-python/jaraco-collections: remove old (diff)
downloadgentoo-1db32248868329eea9b57247b9eb2e3ebc383b37.tar.gz
gentoo-1db32248868329eea9b57247b9eb2e3ebc383b37.tar.bz2
gentoo-1db32248868329eea9b57247b9eb2e3ebc383b37.zip
dev-python/jaraco-logging: bump to 3.0.0, drops <Py3.6, add Py3.8
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jaraco-logging/Manifest1
-rw-r--r--dev-python/jaraco-logging/jaraco-logging-3.0.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/jaraco-logging/Manifest b/dev-python/jaraco-logging/Manifest
index 4aa6976fa1eb..cbb953c7e1a0 100644
--- a/dev-python/jaraco-logging/Manifest
+++ b/dev-python/jaraco-logging/Manifest
@@ -1,2 +1,3 @@
DIST jaraco.logging-1.5.2.tar.gz 7135 BLAKE2B 5235566df80008270f2f28101ab5df1d7fbc1446f138eb4cb851c9bb464b741c0ebb8528d3502130b5c557f30214ec27ce1ea563e09e78776e22d37811da21b5 SHA512 3299adc9c9ca6113198cddbc34147afe1bf453edee16a2d6bfcce64e63deeaff7f87beb74ff44f092435f3433a921b19167fb45778dce444512807357bce1661
DIST jaraco.logging-2.0.tar.gz 10356 BLAKE2B a7522fa9895784a68c8c0af265ad5a82ba27f69e90a17ba18b4a579e1ca5785ad11b7718273adb33661e45e780876b885b581af1b4518ef5322c077ed76242ba SHA512 9262575c3071f78ded2284ebef3a1a80c8ffd60addecf9b215db04471672bd892f6c6bd06a84f9a82e872adf31d45d4eb3faa2884815fcce608840821f49954e
+DIST jaraco.logging-3.0.0.tar.gz 10739 BLAKE2B c5cad0b6d7702a1216869dd0cd388d51a0a8e7bd24000108ef818623b54d23ce1adf0de2e017b869d764342484bf25d676ee18af9647b82964933ebb184cec0e SHA512 bc0edeef6223d0eb78110d51159a70afd16542e830e3cd37dec7628e582bce44218cd7669c03c41125db9824b6fc774f608dd7f6540224659f4dc2f1927d681c
diff --git a/dev-python/jaraco-logging/jaraco-logging-3.0.0.ebuild b/dev-python/jaraco-logging/jaraco-logging-3.0.0.ebuild
new file mode 100644
index 000000000000..2c8fcf0eb31c
--- /dev/null
+++ b/dev-python/jaraco-logging/jaraco-logging-3.0.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Additional facilities to supplement Python's stdlib logging module"
+HOMEPAGE="https://github.com/jaraco/jaraco.logging"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+# TODO: remove six
+# https://github.com/jaraco/jaraco.logging/pull/1
+RDEPEND="
+ >=dev-python/namespace-jaraco-2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/tempora[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ # conf.py looks for '../CHANGES.rst'
+ cd docs || die
+ sphinx-build . _build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ # Override pytest options to skip flake8
+ PYTHONPATH=. pytest -vv --override-ini="addopts=--doctest-modules" \
+ || die "tests failed with ${EPYTHON}"
+}
+
+# https://wiki.gentoo.org/wiki/Project:Python/Namespace_packages#File_collisions_between_pkgutil-style_packages
+python_install() {
+ rm "${BUILD_DIR}"/lib/jaraco/__init__.py || die
+ # note: eclass may default to --skip-build in the future
+ distutils-r1_python_install --skip-build
+}