summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-30 22:30:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-30 22:30:17 +0300
commit1dddc7e0899523ed8612f3aa43044d5c9282d11c (patch)
tree1bf97b0d5ae902120277bd9e56f5e810138d69ba /dev-python
parentdev-python/pika: add 1.3.0, enable tests, PEP517 (diff)
downloadgentoo-1dddc7e0899523ed8612f3aa43044d5c9282d11c.tar.gz
gentoo-1dddc7e0899523ed8612f3aa43044d5c9282d11c.tar.bz2
gentoo-1dddc7e0899523ed8612f3aa43044d5c9282d11c.zip
dev-python/dulwich: add 0.20.44
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.20.44.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index ae0d2eb53abd..23ce166b9e5c 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1 +1,2 @@
DIST dulwich-0.20.43.tar.gz 423604 BLAKE2B e8f6b3fc22ac2289e6529d862f54d8c407725c8d22ba9ee7ddb0d700b4ea617f8b069b14168c43c25cccf6e84592e63f88d3402e58b15413952e5b139bda2c2b SHA512 68ef6e3928a202d76ab882d764d08f8948743825b3b07950a81bd86522c9db6865260c2c725a08b26365719e99343daa1c2a2d242bafe991be2552d06b2e3684
+DIST dulwich-0.20.44.tar.gz 425226 BLAKE2B ba120c682b0fd298a9f17eec524ffdd92af9024e30d0b8c52accda3ef8a1d4876b483e8aaa5f12b4beb73a6c1719ed4504c52396cd355244ab688ceab551faaf SHA512 124a3ae89abf5df9e192919f916012be67112195fc7cfd7c30e814a04d93749a3dc396e12f2d8df1456b113a24cdd1b2f3a1f2733864d5cfad22431a987c25fb
diff --git a/dev-python/dulwich/dulwich-0.20.44.ebuild b/dev-python/dulwich/dulwich-0.20.44.ebuild
new file mode 100644
index 000000000000..95effa84bf17
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.44.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/jelmer/dulwich/
+ https://pypi.org/project/dulwich/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? ( !s390? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) ) )
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}