summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-01-05 16:46:05 -0800
committerBrian Dolbec <dolsen@gentoo.org>2017-01-05 16:48:15 -0800
commit1e4bee97a8391815505f93d1b549081863855226 (patch)
tree68f64054d2692eb0bb1d688cfd2b445350fc1814 /dev-python
parentdev-util/buildbot-worker: Version bump, update 9999 (diff)
downloadgentoo-1e4bee97a8391815505f93d1b549081863855226.tar.gz
gentoo-1e4bee97a8391815505f93d1b549081863855226.tar.bz2
gentoo-1e4bee97a8391815505f93d1b549081863855226.zip
dev-python/moto: Revision bump existing fixing httpretty dep
Version & EAPI bump for 0.4.30 release. Package-Manager: Portage-2.3.3_p7, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/moto/Manifest1
-rw-r--r--dev-python/moto/moto-0.4.22-r1.ebuild (renamed from dev-python/moto/moto-0.4.22.ebuild)10
-rw-r--r--dev-python/moto/moto-0.4.25-r1.ebuild (renamed from dev-python/moto/moto-0.4.25.ebuild)10
-rw-r--r--dev-python/moto/moto-0.4.30.ebuild32
4 files changed, 49 insertions, 4 deletions
diff --git a/dev-python/moto/Manifest b/dev-python/moto/Manifest
index ee9e2e2bbf33..08839d170649 100644
--- a/dev-python/moto/Manifest
+++ b/dev-python/moto/Manifest
@@ -1,2 +1,3 @@
DIST moto-0.4.22.tar.gz 192878 SHA256 07c511f1ebcdf28a4022478bbca6c1e11585f41d0301e8d4525c353d0f7c1d59 SHA512 7a5f1f43dbf6202696705c52a35fde4e046febd403b1e1b0a7e98ae25e881c6a86c29d2f27841db5ce8fe34689cd00ff4d2d711cbfc8817723d2dfa675379f8c WHIRLPOOL 636aeab8991f0b6c5931c2085478bd1cc15df6d15ed04d33500e1848d1095d7e3734dc23b8fbe6aab2f067f8c63733feb96c7a06cc530d9dcdd3bbaaecd5bc9c
DIST moto-0.4.25.tar.gz 329545 SHA256 076307dee26a4287e69b1074af66bf9b192c72e3d2ae03dad5b397ba0c3c15bf SHA512 dce1464d8dca69b3a76585ac58115b75232e18bf9df14e5133f7153d7316ae29bc2fb253476b14b10b01e072ffc7970ab22f1634890bf1d89c4f12ca4f2ccf1e WHIRLPOOL a804049d4fcb851cf10b51293218dfd7b9085f4b95c5ce13a47c8b83cf96d6087976c31e4dc5abf468ee4d968edc042a676a80c0996aa6d7a6bc083ce9996deb
+DIST moto-0.4.30.tar.gz 614008 SHA256 8575b5d19fff0c6046692de6deb2a77968e34eea8a97d6c7e1b2be2148e4867e SHA512 ece27979911f46adbb0aec9aa3755b13c09ced00b24ea136ab9c8a8a992550e9c38dac15d8b0c71822953f070761083253ee5fb5cbe44a4b108d140ab4407699 WHIRLPOOL b277fa02ecf998f4d9120e182310cbced96cd7b79e6f92a8752872bec5bebbd0ebc2c2d759dfbb7d23cc99e9ea046376d0ad403a6c2c03dfda3a56702e44de2e
diff --git a/dev-python/moto/moto-0.4.22.ebuild b/dev-python/moto/moto-0.4.22-r1.ebuild
index cbc557414051..983303cdc7ba 100644
--- a/dev-python/moto/moto-0.4.22.ebuild
+++ b/dev-python/moto/moto-0.4.22-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,8 +20,14 @@ RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
>=dev-python/boto-2.20.0[${PYTHON_USEDEP}]
dev-python/dicttoxml[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpretty-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.8.10[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/xmltodict[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "s/httpretty==0.8.10/httpretty>=0.8.10/" -i setup.py
+
+}
diff --git a/dev-python/moto/moto-0.4.25.ebuild b/dev-python/moto/moto-0.4.25-r1.ebuild
index 2696e78a4567..427d32771817 100644
--- a/dev-python/moto/moto-0.4.25.ebuild
+++ b/dev-python/moto/moto-0.4.25-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -20,8 +20,14 @@ RDEPEND="dev-python/jinja[${PYTHON_USEDEP}]
>=dev-python/boto-2.20.0[${PYTHON_USEDEP}]
dev-python/dicttoxml[${PYTHON_USEDEP}]
dev-python/flask[${PYTHON_USEDEP}]
- >=dev-python/httpretty-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.8.10[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/xmltodict[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/werkzeug[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "s/httpretty==0.8.10/httpretty>=0.8.10/" -i setup.py
+
+}
diff --git a/dev-python/moto/moto-0.4.30.ebuild b/dev-python/moto/moto-0.4.30.ebuild
new file mode 100644
index 000000000000..8c1f98b980b9
--- /dev/null
+++ b/dev-python/moto/moto-0.4.30.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock library for boto"
+HOMEPAGE="https://github.com/spulec/moto"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.36.0[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/httpretty-0.8.10[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -e "s/httpretty==0.8.10/httpretty>=0.8.10/" -i setup.py
+
+}