summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-30 14:20:28 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-30 14:21:36 +0200
commit1e7c761464a83187b2a3794048681c388ce833eb (patch)
treedf532c68125482c40b9eef55c332f522189bee46 /dev-python
parentdev-python/python-mpd: fix DEPEND (testing) (diff)
downloadgentoo-1e7c761464a83187b2a3794048681c388ce833eb.tar.gz
gentoo-1e7c761464a83187b2a3794048681c388ce833eb.tar.bz2
gentoo-1e7c761464a83187b2a3794048681c388ce833eb.zip
dev-python/python-mpd: drop old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-mpd/python-mpd-1.0.0.ebuild43
-rw-r--r--dev-python/python-mpd/python-mpd-1.1.0.ebuild50
2 files changed, 0 insertions, 93 deletions
diff --git a/dev-python/python-mpd/python-mpd-1.0.0.ebuild b/dev-python/python-mpd/python-mpd-1.0.0.ebuild
deleted file mode 100644
index bca3a1df982b..000000000000
--- a/dev-python/python-mpd/python-mpd-1.0.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="Python MPD client library"
-HOMEPAGE="https://github.com/Mic92/python-mpd2"
-SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-SLOT="0"
-IUSE="test +twisted"
-
-REQUIRED_USE="test? ( twisted )"
-
-BDEPEND="
- test? (
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
- )
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-DEPEND="twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )"
-RDEPEND="${DEPEND}"
-
-RESTRICT="!test? ( test )"
-
-DOCS=( doc/changes.rst doc/topics/{advanced,commands,getting-started,logging}.rst README.rst )
-
-S="${WORKDIR}/${PN}2-${PV}"
-
-distutils_enable_tests setup.py
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- rm tox.ini || die
-}
diff --git a/dev-python/python-mpd/python-mpd-1.1.0.ebuild b/dev-python/python-mpd/python-mpd-1.1.0.ebuild
deleted file mode 100644
index de5bfd279256..000000000000
--- a/dev-python/python-mpd/python-mpd-1.1.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS="bdepend"
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python MPD client library"
-HOMEPAGE="https://github.com/Mic92/python-mpd2"
-SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-3+"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-SLOT="0"
-IUSE="examples test +twisted"
-
-REQUIRED_USE="test? ( twisted )"
-
-RDEPEND="twisted? ( dev-python/twisted[${PYTHON_USEDEP}] )"
-
-DEPEND="${DEPEND}"
-
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- )
-"
-
-RESTRICT="!test? ( test )"
-
-DOCS=( README.rst doc/{changes.rst,commands_header.txt} doc/topics/. )
-
-S="${WORKDIR}/${PN}2-${PV}"
-
-distutils_enable_sphinx doc --no-autodoc
-distutils_enable_tests pytest
-
-python_test() {
- pytest mpd/tests.py -vv || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use examples && dodoc -r examples/.
-}