summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-10-21 22:40:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-10-28 23:36:53 +0100
commit1e8deaadf48e8db2769b422b50d4df270799762c (patch)
treeeceb78534d5981c57bddf0e7b2c5a791b38c365f /dev-python
parentdev-python/peppercorn: version bump. (diff)
downloadgentoo-1e8deaadf48e8db2769b422b50d4df270799762c.tar.gz
gentoo-1e8deaadf48e8db2769b422b50d4df270799762c.tar.bz2
gentoo-1e8deaadf48e8db2769b422b50d4df270799762c.zip
dev-python/prompt_toolkit: version bump.
Signed-off-by: Patrice Clement <monsieurp@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/prompt_toolkit/Manifest1
-rw-r--r--dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/prompt_toolkit/Manifest b/dev-python/prompt_toolkit/Manifest
index c0b955e3fda7..a217f76b600e 100644
--- a/dev-python/prompt_toolkit/Manifest
+++ b/dev-python/prompt_toolkit/Manifest
@@ -1 +1,2 @@
DIST prompt_toolkit-1.0.15.tar.gz 243734 BLAKE2B b27e61bb444360abe95714e2014fcacf2355da0540b21af35cc40cb0f0115d0a3b027236235a89a95c1ec1fa947bf5b88b236b737fab5de78e7bd5fc798aa764 SHA512 10981be2ed8b71d0cd9f663c4de047cec9664d9276968c6eec40dc45b388d1acf8eba07d534369254f178931079bf39b04eb2ceac06aa63a2021ebf62387b2f5
+DIST prompt_toolkit-2.0.6.tar.gz 339714 BLAKE2B f969edef98d25930e4d61c1500bb9c8d731dea29e8d154e6baa2ab4045ceaf9d577d46024734a255cc15a4c13685582309e9d2fe7ae3320257f6fd1f9981ada6 SHA512 37082011ee5b8d6fd9febef95c92494ed6108b9ad8c64ac580b69c3464781a2f0dcef5b1c4d06fe309a3036932f7c622042e6b2293acf2ab6f9f2aa3c48d9322
diff --git a/dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild b/dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild
new file mode 100644
index 000000000000..8bf3a1119b10
--- /dev/null
+++ b/dev-python/prompt_toolkit/prompt_toolkit-2.0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Building powerful interactive command lines in Python"
+HOMEPAGE="https://pypi.org/project/prompt_toolkit/ https://github.com/jonathanslenders/python-prompt-toolkit"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die
+}