summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-13 21:44:51 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-13 21:44:51 +0100
commit1f92ec4584bca3d28f6a9652dc26fc7fe1bceb8a (patch)
treeabb6deda75fd92641a21ffb8dcbc23689ffa0e35 /dev-python
parentdev-python/libzilla: Remove old (diff)
downloadgentoo-1f92ec4584bca3d28f6a9652dc26fc7fe1bceb8a.tar.gz
gentoo-1f92ec4584bca3d28f6a9652dc26fc7fe1bceb8a.tar.bz2
gentoo-1f92ec4584bca3d28f6a9652dc26fc7fe1bceb8a.zip
dev-python/nbdime: Remove old
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nbdime/Manifest1
-rw-r--r--dev-python/nbdime/nbdime-0.1.2.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/nbdime/Manifest b/dev-python/nbdime/Manifest
index 30d1e1514f2f..4eb4ff203327 100644
--- a/dev-python/nbdime/Manifest
+++ b/dev-python/nbdime/Manifest
@@ -1,2 +1 @@
-DIST nbdime-0.1.2.tar.gz 3864624 BLAKE2B dbf51b7eb07d08870fe1c629aa294b784fd95c0d547de3a4ea4fcf7da5ad6c490df3b61f3cb353723b3139137a54b534460c2a25a6480f7316b6fd17d742d661 SHA512 9f704645ef1e64b0da260841769068db6f6aba37f30b3c6506a1876af1276acb452ed78f66b9e6d7029f06ed9fabf01a1484b4b86055f27a451d623a7eda90cf
DIST nbdime-0.2.0.tar.gz 4139079 BLAKE2B 1e6994009c8ac291272a297fe583f79123906c9e05ca2afd345c6e230e3c476259c4919e2161a049e46fa28f4490122c53d0a2bc94661683652d226a78fb39be SHA512 c156b706e1d6cc7885f987d746e91d7f0c2fa48885339fd79e778643382ab45e2e52565f45cc73b9a305c6f5177339e875f53ae46d73578443880a4c7522976d
diff --git a/dev-python/nbdime/nbdime-0.1.2.ebuild b/dev-python/nbdime/nbdime-0.1.2.ebuild
deleted file mode 100644
index 0d4e32f604f0..000000000000
--- a/dev-python/nbdime/nbdime-0.1.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_5 )
-
-inherit distutils-r1
-
-DESCRIPTION="Diff and merge of Jupyter Notebooks"
-HOMEPAGE="https://jupyter.org"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="~amd64"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="test webtools"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
- webtools? ( net-libs/nodejs[npm] )
- "
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-cov[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/jsonschema[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
- "
-# The package recommonmark is required to build the docs, not in portage yet.
-# Furthermore, backports.shutil_which is required for python2_7.
-
-python_configure_all() {
- if ! use webtools; then
- mydistutilsargs=( --skip-npm )
- fi
-}
-
-python_test() {
- # user.email and user.name are not configured in the sandbox.
- git config --global user.email "you@example.com" || die
- git config --global user.name "Your Name" || die
-
- distutils_install_for_testing
-
- py.test -l || die
-}