summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-24 08:22:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-24 08:25:18 +0200
commit21858dc81a7ad93b129dbeb9f33c12c4c0aabebc (patch)
treea2166534cfcc3dfb8c2a676b1d8f42447d346295 /dev-python
parentdev-python/diskcache: Bump to 5.0.1 (diff)
downloadgentoo-21858dc81a7ad93b129dbeb9f33c12c4c0aabebc.tar.gz
gentoo-21858dc81a7ad93b129dbeb9f33c12c4c0aabebc.tar.bz2
gentoo-21858dc81a7ad93b129dbeb9f33c12c4c0aabebc.zip
dev-python/hypothesis: Bump to 5.28.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.28.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 76e88569101e..18ac8939a3a7 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-5.21.0.tar.gz 9025422 BLAKE2B acd6f3b0f945ae65656af2a718a
DIST hypothesis-python-5.24.3.tar.gz 9050345 BLAKE2B bfb47794edb3c1c6aee22e808a6d27af52f8176d307f9a585efa0f1e0d68adf9a902ed6f67405e77c6804f18e17a76486ab42f610807f6ee97535f950318a055 SHA512 7647d14ba805ad3ff6465e1d2c6d9104560c7ea31517777ab45e07da39efefa7109215d2f4074082620554ae4aa5ce5060bca5c923d11c14718f1efdae829986
DIST hypothesis-python-5.24.4.tar.gz 9054743 BLAKE2B 5c64c86ed58d8f0e4a07390b1b1b5e405878b9632bf14233e0515ad9d98ec6ddcc57bf39be6b61f53739d34e393b3af64c0d362880019d29a649a9523a0204e3 SHA512 147f4fa47b54bf3ec4dfcebf2a6c98cee26ea6780244ef99e181bada65978375ca7731ed05cb98f1b92f7a44a357faae374d97d489ec6e2318ff94e526cd9a40
DIST hypothesis-python-5.27.0.tar.gz 9067945 BLAKE2B 29cd1fd1b7cd4a2258a84d4dc122284c1cc8f21da2604e3b6c800a3bb43687eed7a3eb5b33373000c7c1359a3ff08326107d878910a0d92817c0c29c743dd1fa SHA512 973ab33c69d2db58ca3550335be3cc4196ccf532ccc2c0aeb0b54459201904c06f289a9f6faa3bfa77f6704a6f43e253e34453110cda750a2a1a19a851038dda
+DIST hypothesis-python-5.28.0.tar.gz 9069739 BLAKE2B c7b404b815053441a7446c947a03a50eaf3030cb2b0387dda697e677af94b1b90e7570603ef3b4f8b26b9afbcdfc1b3708f713202c4a3617c73494f9e13781aa SHA512 7d3f7a88d70d48465a5bb6b995a73dafc4273f4a0cc3d3f2ee0ae125e1b2f52b9a840268acebf80f4dd1e86b5b5998996f2506a665f24044643a299aded0ced1
diff --git a/dev-python/hypothesis/hypothesis-5.28.0.ebuild b/dev-python/hypothesis/hypothesis-5.28.0.ebuild
new file mode 100644
index 000000000000..fcf6b2610385
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.28.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..8})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python3.[678] ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}