summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-20 12:34:46 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-20 12:48:51 +0200
commit21861b8357979fa1c9c213b4c866e6640f5645dd (patch)
treee6956f4b9b3f86b2bdf3ef29f62dacf321b3d178 /dev-python
parentdev-python/aiotest: Add package needed for aioeventlet tests (diff)
downloadgentoo-21861b8357979fa1c9c213b4c866e6640f5645dd.tar.gz
gentoo-21861b8357979fa1c9c213b4c866e6640f5645dd.tar.bz2
gentoo-21861b8357979fa1c9c213b4c866e6640f5645dd.zip
dev-python/aioeventlet: Enable the test suites
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aioeventlet/aioeventlet-0.5.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/aioeventlet/aioeventlet-0.5.1-r1.ebuild b/dev-python/aioeventlet/aioeventlet-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..aa62e061ff83
--- /dev/null
+++ b/dev-python/aioeventlet/aioeventlet-0.5.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="asyncio event loop scheduling callbacks in eventlet"
+HOMEPAGE="https://pypi.python.org/pypi/aioeventlet https://bitbucket.org/haypo/aioeventlet"
+SRC_URI="mirror://pypi/a/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/eventlet[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/trollius-0.3[${PYTHON_USEDEP}]' 'python2_7')"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/aiotest[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2_7') )"
+
+python_test() {
+ # from tox.ini
+ "${PYTHON}" runtests.py -v || die "Tests fail with ${EPYTHON}"
+ "${PYTHON}" run_aiotest.py -v || die "Tests fail with ${EPYTHON}"
+}