summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 06:22:48 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:22:48 +0000
commit21ca469506090b3090f6a961949f86f0a8f85cb4 (patch)
treeee98242028052bd11db2e5cc4b8c26d5fd575c97 /dev-python
parentdev-python/peewee: minor changes (diff)
downloadgentoo-21ca469506090b3090f6a961949f86f0a8f85cb4.tar.gz
gentoo-21ca469506090b3090f6a961949f86f0a8f85cb4.tar.bz2
gentoo-21ca469506090b3090f6a961949f86f0a8f85cb4.zip
dev-python/isort: bump to 5.7.0
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/isort/Manifest1
-rw-r--r--dev-python/isort/isort-5.7.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/isort/Manifest b/dev-python/isort/Manifest
index b716e2ff9e4b..5fa3daa7f3d0 100644
--- a/dev-python/isort/Manifest
+++ b/dev-python/isort/Manifest
@@ -1,3 +1,4 @@
DIST isort-4.3.15.tar.gz 67949 BLAKE2B e78960518928cd74c15733bbc14bf066798ecbcc3e906754c10e352e7b88843451a1d0616d1b450100c77e95974f863951d640c9568277e867fcdfba8f44abdb SHA512 a5774d4f3c49c978e9043e52681e80011591422e60178d72074142725d9d7fa5065553686fd42bffe9e71b38b2b5bdaaa6f20e32cd8dbe33beb9431c397d78e5
DIST isort-4.3.21_p2.tar.gz 158539 BLAKE2B 316703ca754c939e4af0db4a1060fb13a5164797a672b3faeb585a81fa0c86453fb0f1953b789661588cd0f04267a28837d46a88093a838391f752afa43e9f8b SHA512 fc2aa00c87196864864d2516b8be7acdedcf40d71d1931510e4b878dbd2b6da0b579661b50221f03f4aa5560c8bf23d5e1e10a2694d2b741ca09a92e40a4c687
DIST isort-5.6.3.tar.gz 161712 BLAKE2B ffbc2977016807d2bd5b1644377efad021af2ad27fd0e27feae1e5dfdfd112c7b5bf4b296ebf47ea6bfcbfe7f56cf3bfa8e1e7cf03963935660e678223397afb SHA512 fa2d9be306d03fc802aab3915bee2c41f4fe0c28353d9d99aa6604755e1602027cd81afca92b4302f80497c88a9dcb2701ec02ca55a5f9a2866669a68368d957
+DIST isort-5.7.0.tar.gz 169353 BLAKE2B bafd6a0ce81ed80a3c1ad53ce320361ef11bc01a78211ad13b7947aafddd4d9bb5a4fbf65ec01d4c90dce7ebd0a2e3b1c4dcad729b1e27b1dd2c5c90c802eecf SHA512 ae5ff56394f495f6bd86f7581e0f8a67264671553b344b9dc2c5ba0b37f483ae500ebba9882ff5c315b913a689901b17de2eac403e0b4240f913c9e1864bab9f
diff --git a/dev-python/isort/isort-5.7.0.ebuild b/dev-python/isort/isort-5.7.0.ebuild
new file mode 100644
index 000000000000..895d37aadc39
--- /dev/null
+++ b/dev-python/isort/isort-5.7.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A python utility/library to sort imports"
+HOMEPAGE="https://pypi.org/project/isort/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pylama[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # Some tests run the "isort" command
+ distutils_install_for_testing --via-root
+
+ local skipped_tests=(
+ # Fails without -s, run it separately to avoid unnecessary output
+ tests/unit/test_importable.py
+ # Excluded from upstream's test script
+ tests/unit/test_deprecated_finders.py
+ # Require "example_isort_formatting_plugin", we're not going
+ # to add an example package just to run a few tests
+ tests/unit/test_literal.py::test_value_assignment_list
+ tests/unit/test_ticketed_features.py::test_isort_supports_formatting_plugins_issue_1353
+ tests/unit/test_ticketed_features.py::test_isort_literals_issue_1358
+ # Same here: requires "example_shared_isort_profile"
+ tests/unit/test_ticketed_features.py::test_isort_supports_shared_profiles_issue_970
+ )
+ pytest -s tests/unit/test_importable.py \
+ || die "Tests failed with ${EPYTHON}"
+ pytest -vv tests/unit ${skipped_tests[@]/#/--deselect } \
+ || die "Tests failed with ${EPYTHON}"
+}