summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-30 08:47:29 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-30 08:49:39 +0200
commit2202562d55dbbd079a91a462dd84fa8d75a997ef (patch)
treeab917a6ebedbc2c813ca63ac9e2d9ef353ea34bc /dev-python
parentdev-python/nbsphinx: Remove old (diff)
downloadgentoo-2202562d55dbbd079a91a462dd84fa8d75a997ef.tar.gz
gentoo-2202562d55dbbd079a91a462dd84fa8d75a997ef.tar.bz2
gentoo-2202562d55dbbd079a91a462dd84fa8d75a997ef.zip
dev-python/python-box: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-box/Manifest1
-rw-r--r--dev-python/python-box/python-box-7.0.1.ebuild52
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-python/python-box/Manifest b/dev-python/python-box/Manifest
index fe800b65b7b7..19f8e6c78cf2 100644
--- a/dev-python/python-box/Manifest
+++ b/dev-python/python-box/Manifest
@@ -1,2 +1 @@
-DIST Box-7.0.1.gh.tar.gz 86746 BLAKE2B 33288c89d1b285d1c04ebb00d56a26d451f7b22eefbcef12219108975aa610054af67f69153436033a183c7b26cf216649ddc75b4354f2ff4f02f2a6fc2903bd SHA512 fe08fbca79fa02e53bc4208387162e49917f302e1595d924d4290d690092a9f7fae3f0cac66de1fd48ef16e627c4fbc2b2babed52b04381b24dab9b083040cf7
DIST Box-7.1.1.gh.tar.gz 87515 BLAKE2B 388944c3a577105ce1e12e9abff7da148d028db88d8070a09e6abe190882acdbfa4cf9d773af6cbae7e945603dc13d3d853253dc18b0d2d2b17c678293583b8a SHA512 60e44eda013a5ab1de2215d156caf2567a24b0471ee20e52096137ad761e92c3ca20d9f3967a21e38ac924488a2b76399c4ea1bc86b652dd72d7494ce22effee
diff --git a/dev-python/python-box/python-box-7.0.1.ebuild b/dev-python/python-box/python-box-7.0.1.ebuild
deleted file mode 100644
index c300e79fa62f..000000000000
--- a/dev-python/python-box/python-box-7.0.1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1
-
-MY_P=Box-${PV}
-DESCRIPTION="Python dictionaries with advanced dot notation access"
-HOMEPAGE="
- https://github.com/cdgriffith/Box/
- https://pypi.org/project/python-box/
-"
-SRC_URI="
- https://github.com/cdgriffith/Box/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-
-RDEPEND="
- dev-python/msgpack[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.8 3.9 3.10)
- dev-python/tomli-w[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # looks like broken tests
- # https://github.com/cdgriffith/Box/issues/257
- test/test_box.py::TestBox::test_box_kwargs_should_not_be_included
- test/test_box.py::TestBox::test_box_namespace
- )
-
- rm -rf box || die
- epytest
-}