summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-14 13:35:27 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-14 14:01:12 +0200
commit234fa23b74ace56f720c33b66dabf1f254988de5 (patch)
tree69c77d3451d50168df23cc431d137d816f1cdd5f /dev-python
parentdev-python/GitPython: Bump to 3.1.7 (diff)
downloadgentoo-234fa23b74ace56f720c33b66dabf1f254988de5.tar.gz
gentoo-234fa23b74ace56f720c33b66dabf1f254988de5.tar.bz2
gentoo-234fa23b74ace56f720c33b66dabf1f254988de5.zip
dev-python/hypothesis: Bump to 5.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.19.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 3ced917bc5d2..e7f559cc2cd5 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,3 +4,4 @@ DIST hypothesis-python-5.16.0.tar.gz 9011031 BLAKE2B 65659f72094ac7fcc82c7e5a8b8
DIST hypothesis-python-5.16.3.tar.gz 9011952 BLAKE2B d74a68c4ee1e5aacf4be1da5a4656011b0a15f990106c21298101d36e9a097c5dfd165987ad90a45f3a0b74375c4da609cd750f618242b94f34e03b6de0ee866 SHA512 912d984995d4ad8f06e98eb2cc327629328990fc1c072527ce261b637e16622acaf4d0d93928f9dd2d6601ab78f69aa6cf129d5cd7c1c00e50754ebc06957df0
DIST hypothesis-python-5.19.0.tar.gz 9022213 BLAKE2B d8996cfd18d24722cd4faaf8335ce2b1c67757e3ffe973a33bd8ad087fcde513442d9fdf01f486ee07b33504e4088aa9e4c104782c3b03aa4f0d77a99ba6f672 SHA512 c26b0c9c5c7e1941c7f491e8e8165fda86a6e985204b9098c214080e508167f77f7dffe65192a4418f4958c3c6df44a20d75131895517c40c1113995ace3b604
DIST hypothesis-python-5.19.1.tar.gz 9023768 BLAKE2B d1aa7c7a537e9f4ac0f33c12fa0c8269917aa83c01b8e333492d22ac8642ea29f678ca94d6f3d6c45efce7a2fd178d7cab6bcdfefef57c19e84c559a9affd8bd SHA512 81397f64f79debcea05f343f7c8c7cb528231be0bea15f0c6b81e3f68278eff6d73fa09a2f85a798c58468087b6135fea21530402a8fb9bd8014c040ad54a8c4
+DIST hypothesis-python-5.19.2.tar.gz 9023874 BLAKE2B e4c713a574547eccfd9d9fc36c2ef192795922c7fc97eb8a59a61506d2d89101a02e0f81fda3d703aac03ed4dc902f47f07ea50375efbc5b1ae7c24f7ea3f058 SHA512 f0a55e8039666dc664760483e6a6cae3371b627912f89215c76430d71bfc80426beef3001dd7415686d75387ceb1a0810068fded11ec728d20f81936bd0b9717
diff --git a/dev-python/hypothesis/hypothesis-5.19.2.ebuild b/dev-python/hypothesis/hypothesis-5.19.2.ebuild
new file mode 100644
index 000000000000..54efc2972e96
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.19.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+src_prepare() {
+ # avoid pytest-xdist dep for one test
+ sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
+ tests/pytest/test_statistics.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}