summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-22 19:48:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-22 20:20:47 +0300
commit236404afafdf9e07eee0d292f4b5717bccb582f1 (patch)
tree6e5bca6977560b169d6c4d09d52b502d08138016 /dev-python
parentdev-python/citeproc-py: enable py3.10 (diff)
downloadgentoo-236404afafdf9e07eee0d292f4b5717bccb582f1.tar.gz
gentoo-236404afafdf9e07eee0d292f4b5717bccb582f1.tar.bz2
gentoo-236404afafdf9e07eee0d292f4b5717bccb582f1.zip
dev-python/duecredit: enable py3.10, small cleanup
Closes: https://bugs.gentoo.org/812374 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/duecredit/duecredit-0.9.1.ebuild20
1 files changed, 5 insertions, 15 deletions
diff --git a/dev-python/duecredit/duecredit-0.9.1.ebuild b/dev-python/duecredit/duecredit-0.9.1.ebuild
index da81018c7a20..ad8014870d45 100644
--- a/dev-python/duecredit/duecredit-0.9.1.ebuild
+++ b/dev-python/duecredit/duecredit-0.9.1.ebuild
@@ -3,10 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Publications (and donations) tracer"
@@ -21,18 +18,11 @@ RDEPEND="
>=dev-python/citeproc-py-0.4[${PYTHON_USEDEP}]
dev-python/requests[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- ' python3_7)
"
distutils_enable_tests pytest
-python_test() {
- local deselect=(
- # internet?
- 'duecredit/tests/test_api.py::test_noincorrect_import_if_no_lxml_numpy[kwargs1-env2]'
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
+EPYTEST_DESELECT=(
+ # internet?
+ 'duecredit/tests/test_api.py::test_noincorrect_import_if_no_lxml_numpy[kwargs1-env2]'
+)