summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-03-30 22:25:54 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-03-31 09:03:02 -0400
commit244ad5e2f26287ae3975788b00dd7568e3d07779 (patch)
treee8bd21c46c3836cef75813501b2ea74fb49284f8 /dev-python
parentdev-python/sphinxcontrib-serializinghtml: new package (diff)
downloadgentoo-244ad5e2f26287ae3975788b00dd7568e3d07779.tar.gz
gentoo-244ad5e2f26287ae3975788b00dd7568e3d07779.tar.bz2
gentoo-244ad5e2f26287ae3975788b00dd7568e3d07779.zip
dev-python/sphinxcontrib-qthelp: new package
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-qthelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-qthelp/metadata.xml11
-rw-r--r--dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild27
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-qthelp/Manifest b/dev-python/sphinxcontrib-qthelp/Manifest
new file mode 100644
index 000000000000..ddc066c54d7b
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-qthelp-1.0.2.tar.gz 17804 BLAKE2B f3d6a67469c82e2a6e90b75d506ee3faa896d8ec408d60f93f74c8cc4bafb22772f85e36c286a96cecf2d7808338da233910055404969ef311f935173f06f376 SHA512 8fe840e011fabd596194f539d27a502b77ae8a6030ae1a7646b1af9f203d3578b7420ead655297b2a752f0cb0e6803247c7a79b2ccd2d4662ed9f58398947864
diff --git a/dev-python/sphinxcontrib-qthelp/metadata.xml b/dev-python/sphinxcontrib-qthelp/metadata.xml
new file mode 100644
index 000000000000..a830ee0b076f
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-qthelp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild
new file mode 100644
index 000000000000..e9c1a10e87b8
--- /dev/null
+++ b/dev-python/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs QtHelp documents"
+HOMEPAGE="http://www.sphinx-doc.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND=""
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}