summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-05 09:57:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-05 11:41:11 +0200
commit25d5ee1a16e2f7d72be3fa54234507dafecea50e (patch)
tree44ea66b6785c1c3661aa34259e0cc7848699ec0f /dev-python
parentdev-python/awxkit: Remove old (diff)
downloadgentoo-25d5ee1a16e2f7d72be3fa54234507dafecea50e.tar.gz
gentoo-25d5ee1a16e2f7d72be3fa54234507dafecea50e.tar.bz2
gentoo-25d5ee1a16e2f7d72be3fa54234507dafecea50e.zip
dev-python/nbconvert: Bump 7.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nbconvert/Manifest1
-rw-r--r--dev-python/nbconvert/nbconvert-7.1.0.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/nbconvert/Manifest b/dev-python/nbconvert/Manifest
index 9b70905386fd..89000fc9f1c0 100644
--- a/dev-python/nbconvert/Manifest
+++ b/dev-python/nbconvert/Manifest
@@ -2,3 +2,4 @@ DIST nbconvert-6.5.0.tar.gz 908377 BLAKE2B a91c6c93e9e33f90c5c7f19743e20aa6cf88e
DIST nbconvert-6.5.2.tar.gz 910454 BLAKE2B 0c80232697e1ecf31af17f10ae5ad9bcfaec89e06ab5f81c87f231f2abd585c23977d0b154363e72f6066a97d04ec96184b0d8325e5aaa399a1a9335109577bb SHA512 b955bd55bc1f69700652faae12a585230d939877551f792eebee57936a293b9b54caff5eb1bcaf996efa38c737f141069d4af2c2959b8b6318966c9020e8a2f5
DIST nbconvert-6.5.3.tar.gz 910597 BLAKE2B a6336f2227098caf1d59aafa770fc3dd3466160329d5344dc760425cdde7ca35ad8d1e8839fe3189d1623a682a61ea3feedb7fdfdb2ec349e6ec890d873a936a SHA512 a991d8a66fe7a244d3943974d93eb13769016843d37f6c9dcf4ba84dd16511364f45b5020060bf2c10d35fe52b4df4b678d045eedc883d3156a6cb689a977525
DIST nbconvert-7.0.0.tar.gz 860724 BLAKE2B f333145df45f7295259e964f50a68ab6c33f195c42f68deddc87d23348761cc816e9bfbe4552b2a0276ca28a9f0820183f118b531cdb1f1f8ca4355dc5486f3d SHA512 3c458a757060f1c9165c5ae7f0b5aad53be29d50ac385a37567007a5ac4fe67987592c66ba048e3659d089e9ac1ef210f14b750b5215bc181197c86257223b85
+DIST nbconvert-7.1.0.tar.gz 816516 BLAKE2B c24766716212247dee90ca91a5dbcc65ae2d47b566029eb04e14e65ef94e16f6d7700ea4cc820584bc3b498553196bb5600151a30378ec82f91bf4dde68a5e77 SHA512 5d6e1c09637765e171336528219669a9279a68f3845cb0503b79129b50550f7b5a08526a30de67da6ca132ee5d911743c5afd46773598d6045f3007167f93d5b
diff --git a/dev-python/nbconvert/nbconvert-7.1.0.ebuild b/dev-python/nbconvert/nbconvert-7.1.0.ebuild
new file mode 100644
index 000000000000..eb24c46391ff
--- /dev/null
+++ b/dev-python/nbconvert/nbconvert-7.1.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Converting Jupyter Notebooks"
+HOMEPAGE="
+ https://nbconvert.readthedocs.io/
+ https://github.com/jupyter/nbconvert/
+ https://pypi.org/project/nbconvert/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.6[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_core-4.7[${PYTHON_USEDEP}]
+ dev-python/jupyterlab_pygments[${PYTHON_USEDEP}]
+ >=dev-python/markupsafe-2.0[${PYTHON_USEDEP}]
+ >=dev-python/mistune-2.0.2[${PYTHON_USEDEP}]
+ >=dev-python/nbclient-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.1[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pandocfilters-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.1[${PYTHON_USEDEP}]
+ dev-python/tinycss2[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/notebook[${PYTHON_USEDEP}]
+ test? (
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ >=dev-python/ipywidgets-7[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ mkdir share/templates/classic/static || die
+ # tries to refetch stuff even if it's already present
+ sed -e 's:css = .*:raise PermissionError("You shall not fetch!"):' \
+ -i hatch_build.py || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ cp "${BROOT}$(python_get_sitedir)/notebook/static/style/style.min.css" \
+ share/templates/classic/static/style.css || die
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Missing pyppeteer for now
+ # TODO: Doesn't skip?
+ nbconvert/exporters/tests/test_webpdf.py
+ # Needs pyppeteer too
+ 'nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_webpdf_with_chromium'
+ # TODO
+ nbconvert/exporters/tests/test_qtpng.py::TestQtPNGExporter::test_export
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_convert_full_qualified_name
+ nbconvert/tests/test_nbconvertapp.py::TestNbConvertApp::test_post_processor
+ )
+
+ nonfatal epytest --pyargs nbconvert || die
+}
+
+pkg_postinst() {
+ if ! has_version app-text/pandoc ; then
+ einfo "Pandoc is required for converting to formats other than Python,"
+ einfo "HTML, and Markdown. If you need this functionality, install"
+ einfo "app-text/pandoc."
+ fi
+}