summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-04 23:36:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-05 04:15:13 +0200
commit27433050df15582694286ece4645bc1ffbdeaeac (patch)
tree4f1f8e29a5b06936e906692526dee234a1786555 /dev-python
parentsci-mathematics/giac: pari 2.15 compat + -gui workaround (diff)
downloadgentoo-27433050df15582694286ece4645bc1ffbdeaeac.tar.gz
gentoo-27433050df15582694286ece4645bc1ffbdeaeac.tar.bz2
gentoo-27433050df15582694286ece4645bc1ffbdeaeac.zip
dev-python/ytmusicapi: bump to 0.24.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ytmusicapi/Manifest1
-rw-r--r--dev-python/ytmusicapi/ytmusicapi-0.24.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/ytmusicapi/Manifest b/dev-python/ytmusicapi/Manifest
index 5fe09c2d2467..6f4c3119a148 100644
--- a/dev-python/ytmusicapi/Manifest
+++ b/dev-python/ytmusicapi/Manifest
@@ -1,2 +1,3 @@
DIST ytmusicapi-0.22.0.tar.gz 50474 BLAKE2B cd0d3a0c45a754560cb70b1766888d76a4b4c1b956f0112d761b1ee8663d7ed792c2befc71c5430464daacb19b7bcff48b7e2d079fd5de08db4583a110b4002a SHA512 3286e67e80c5b73e18b7d30040faca76d790b1b4ac45e635d721f5465379d525af89e6f6635353d3849c43d67c8b59a632423d3bee5a24a2e9c993cc009f2286
DIST ytmusicapi-0.23.0.tar.gz 56717 BLAKE2B 39483ecfb90fe902a33cf535d8a13f55d2d1ff4aa2e6b00b6e8cee4547b46f915dc75c86dc0dcfb876eca74d17c4810ebc1e210863d5588b9b084a14cd6f6570 SHA512 401cf7908b77f3f8279d510992c242c0d75cd97b6566b79743421d8c3eee456d6ccb6b09bad8b3582a166c7dc4688e68846131fe90b725fa1c257a4202a3d148
+DIST ytmusicapi-0.24.0.tar.gz 57431 BLAKE2B ba0ceee4764ff0c09efe309ef7182001d0d0dcd8e959b0b0b3e31b267986896728f67cbda14a33e8935068d551f24509de4364877c5810a29ef8b59bc0324291 SHA512 bec107edaec064aaec300a812a56f70b8eb6a217f2dba9e10a745f9315fe9e89ccef2e05619ae236efd21a9ced0fa414f35d9180e2f9efdc40fe8c75b41e9eb4
diff --git a/dev-python/ytmusicapi/ytmusicapi-0.24.0.ebuild b/dev-python/ytmusicapi/ytmusicapi-0.24.0.ebuild
new file mode 100644
index 000000000000..f7bf16281852
--- /dev/null
+++ b/dev-python/ytmusicapi/ytmusicapi-0.24.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unofficial API for YouTube Music"
+HOMEPAGE="https://ytmusicapi.readthedocs.io/
+ https://github.com/sigma67/ytmusicapi/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme