summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-07-12 17:33:49 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-12 20:49:33 +0200
commit27c6357e8da239117e053c45e378f93025742bc3 (patch)
treebf291d71971939aa59a58a084044d5e257a02603 /dev-python
parentdev-python/sphinx: Remove unnecessary pytest-cov dep (diff)
downloadgentoo-27c6357e8da239117e053c45e378f93025742bc3.tar.gz
gentoo-27c6357e8da239117e053c45e378f93025742bc3.tar.bz2
gentoo-27c6357e8da239117e053c45e378f93025742bc3.zip
dev-python/sphinx: Disable test_theme_api due to fragility
Disable test_theme_api as it fails whenever additional Sphinx themes are installed.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/sphinx-1.7.5-r1.ebuild3
1 files changed, 3 insertions, 0 deletions
diff --git a/dev-python/sphinx/sphinx-1.7.5-r1.ebuild b/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
index 1b87b472641d..fc0dcb5a9423 100644
--- a/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
+++ b/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
@@ -64,6 +64,9 @@ python_prepare_all() {
rm tests/test_websupport.py || die "Failed to remove web tests"
rm tests/test_build_linkcheck.py || die "Failed to remove web tests"
+ # fails when additional sphinx themes are installed
+ sed -i -e 's:test_theme_api:_&:' tests/test_theming.py || die
+
distutils-r1_python_prepare_all
}