summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 09:00:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 10:28:28 +0200
commit27f6590ecb1ad23d133ccd2214ed5b957dcc7a09 (patch)
tree471d17fad72e27e0f14a6c14ab9b5d2980dee5b7 /dev-python
parentsci-mathematics/z3: Bump to 4.8.11 (diff)
downloadgentoo-27f6590ecb1ad23d133ccd2214ed5b957dcc7a09.tar.gz
gentoo-27f6590ecb1ad23d133ccd2214ed5b957dcc7a09.tar.bz2
gentoo-27f6590ecb1ad23d133ccd2214ed5b957dcc7a09.zip
dev-python/pyls-black: Bump to 0.4.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyls-black/Manifest1
-rw-r--r--dev-python/pyls-black/pyls-black-0.4.7.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyls-black/Manifest b/dev-python/pyls-black/Manifest
index 2dc576125c41..a35ed3557d9d 100644
--- a/dev-python/pyls-black/Manifest
+++ b/dev-python/pyls-black/Manifest
@@ -1 +1,2 @@
DIST pyls-black-0.4.6-gh.tar.gz 5121 BLAKE2B fb1265d40e7c8b85d066d8d3078a60ff719992abcd84efc9d9df582d6fd7e47f211dbed004081413955524e9455218085d78f1d843769a40168ac448139e283c SHA512 e9fa3faec0fb3f2a8bcbdd4c9b8b8e6662d1bcafa88f693b09e2a7a4df8c2d35df8d8f79c50bbb33342a07cde8931e7f136136ff40879898612b13bdff7277fc
+DIST pyls-black-0.4.7.gh.tar.gz 5166 BLAKE2B 46ed7dc96b9f3b70edd1923133b39169b37f0d2d909bed41742690920dd7ea9b935dfa17b8d8f8ab43d9e3b3e18a99811c015ae5506e950e8775df8a34c79a83 SHA512 a68861a8283ab9118fa0a5bad6a751d5ece422813de12c98eba624d97742cf3f4e0b02d3afa43fb129bac00c54b9b2702bafd590d2d1489bd4af773ee68db7b3
diff --git a/dev-python/pyls-black/pyls-black-0.4.7.ebuild b/dev-python/pyls-black/pyls-black-0.4.7.ebuild
new file mode 100644
index 000000000000..825e437521bf
--- /dev/null
+++ b/dev-python/pyls-black/pyls-black-0.4.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Black plugin for the Python Language Server"
+HOMEPAGE="https://github.com/rupert/pyls-black
+ https://pypi.org/project/pyls-black/"
+SRC_URI="https://github.com/rupert/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/python-language-server[${PYTHON_USEDEP}]
+ >=dev-python/black-21[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests --install pytest