summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-19 06:05:11 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-19 07:10:51 +0100
commit281f6daa5edd4e7efef3396a22d55b56f24b3d0a (patch)
treecdd846503548018ed4239871af91029b2b2a576d /dev-python
parentdev-python/chameleon: Bump to 4.4.2 (diff)
downloadgentoo-281f6daa5edd4e7efef3396a22d55b56f24b3d0a.tar.gz
gentoo-281f6daa5edd4e7efef3396a22d55b56f24b3d0a.tar.bz2
gentoo-281f6daa5edd4e7efef3396a22d55b56f24b3d0a.zip
dev-python/botocore: Bump to 1.34.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 6bef72d668b1..ac6a6223439f 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.33.11.gh.tar.gz 12536159 BLAKE2B bce09ad1b93210667e3c1058ab3b435
DIST botocore-1.33.6.gh.tar.gz 12516087 BLAKE2B da3ca22acb5b6ee27eb3c0f7dab4ad43597ab985aa7512f4f4a51c2ca3db80a049e13faaf986dd4a02125f92c088129506651125a826184656250665dc7b7128 SHA512 cae5019d85c9b3afcfd93fe58d0e51c5a6e0769d58b2a8b1285a34ce66be8db34e9c5dc4dc74ff72e0992cdd142d101e3663fa1d68a2779fa9c09de37d2f2001
DIST botocore-1.34.1.gh.tar.gz 12561522 BLAKE2B 67b42866c4a00ea960b8d942110acdf9fd642e9164c987e12f9e12ceee37b1c4d9be59a3185006c19b52c31b957442fe4fa9de9d4d1d697854c0c1c7b9eb23cc SHA512 04cba828baf7bb14f2cb2a3eedca6332842ca1d0c8d1e5ad837607ea6c5fe1564a222c516835d7f67e2fea85490032ef04d61d631c0cff6849ee7cdca5eeabf4
DIST botocore-1.34.2.gh.tar.gz 12564834 BLAKE2B b22a3d3bd35b769a28ccb1a5116428e1904d0c9fc3452829237704dbec37a31a539f044a728b0785d09406d299d522dd601da39801249747d54e6741b46cafe2 SHA512 a3f3718bf584a871abbb3edc803de9d5329da257c050d56bdbf8a6a6c4067477812582fbd8d1d789ce18ea1f416d0ddb2be9cc3c45172292d061a94a12f3977b
+DIST botocore-1.34.3.gh.tar.gz 12574694 BLAKE2B f171337299c886d0b9c78e50ea57b0e2c1cf3cf261bbaca5e69bd374898ced32cf085d43d7a5f935d16573411e88f432f8417f047391f0a8de914886f14fe7ea SHA512 7e74536e6a69d25aff66763e7c817d5a3b54cb9c528a20be758c490621f33c945cb63313391bb25e402aab32a5b3fbb19215118c02559b64983c21db8ca79bc2
diff --git a/dev-python/botocore/botocore-1.34.3.ebuild b/dev-python/botocore/botocore-1.34.3.ebuild
new file mode 100644
index 000000000000..05766e84276c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}