summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-01-29 16:21:06 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-01-29 16:21:19 -0800
commit287815fe9e64f5a6ec1be6072ddb5d20256eec63 (patch)
treecb0255bfec81d3ce5fad7c263630a05325ef1621 /dev-python
parentdev-python/astroid-2.3.3: Version bump, add py38 (diff)
downloadgentoo-287815fe9e64f5a6ec1be6072ddb5d20256eec63.tar.gz
gentoo-287815fe9e64f5a6ec1be6072ddb5d20256eec63.tar.bz2
gentoo-287815fe9e64f5a6ec1be6072ddb5d20256eec63.zip
dev-python/pylint-2.4.4: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pylint/Manifest1
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch12
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch13
-rw-r--r--dev-python/pylint/files/pylint-2.4.4-tests.patch13
-rw-r--r--dev-python/pylint/pylint-2.4.4.ebuild58
5 files changed, 97 insertions, 0 deletions
diff --git a/dev-python/pylint/Manifest b/dev-python/pylint/Manifest
index ee1e8267508a..0ce1aa3a79bd 100644
--- a/dev-python/pylint/Manifest
+++ b/dev-python/pylint/Manifest
@@ -1,3 +1,4 @@
DIST pylint-1.6.5.tar.gz 465578 BLAKE2B 05412a528878633ef7529dd2f2d2d1989bc9406666626d62764f476bbc024e34fea06883fae829fe6617ebfffde54dfa5600c140b9a25e6c9633f48d76f5c331 SHA512 2fac352dc752b37f1ce4f7fefe5afbbc880d7e6c38f164d1c50734716af1dd6fe31f7d41e145a8256837d5a63b1989efec40c169fc14840cf8eb4e18d9bb2410
DIST pylint-1.8.4.tar.gz 512582 BLAKE2B 623e224ec71756cc2528346ac62b8e58ac4d5ef55d9e31e667d5389aa5b2dad712f60c7e90df5c831f57bf28e0ccbd00ddece4ade46410c28b67adb1a041a85f SHA512 07e55ed3f09326e1973215046e3b172f6065a7ed0ae657cba7a6825a26bb103bdbf8b83126bafd99f332fe0eec3547bcd6e618d6e9f612ddcf9c504bb850dcd9
DIST pylint-2.3.1.tar.gz 577767 BLAKE2B 2af206a9d9be04f369c2bbc39c5ddb80c29a5a39c20d75bfec84498882eab628a7cf5abcc5786933304ed99bd00ffa142b9a58abab348c947799f962b877bb30 SHA512 924d8adc95f04ba750b3b44fe79ac569151ea7c8f693cc9867bcda3878209ebc2202931702b98f80709d161d3781b6e181aea0ded35a3323c023497e2a749ea9
+DIST pylint-2.4.4.tar.gz 646113 BLAKE2B d62b66b056e01cc13e90f45ff4a11f94983e0b9b42b9a05e5c7b7385280000d15ead9a282e7eea31a8ee6a24ffe539576a6e9bd40dc4d89093263da99029123b SHA512 835e0687ebc76c530e0042c5a5188b8aedab446531f621627e990cbeb37ab6ecc8de0f8c6ab171abaa63488e049e8d7782958461421f9a4127435f56b6d2ed0b
diff --git a/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch b/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch
new file mode 100644
index 000000000000..0d668d01cdc9
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.4.4-no-pytest-runner.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 4d16b79b..b2a1b9e9 100644
+--- a/setup.py
++++ b/setup.py
+@@ -143,7 +143,6 @@ def install(**kwargs):
+ extras_require=extras_require,
+ test_suite="test",
+ python_requires=">=3.5.*",
+- setup_requires=["pytest-runner"],
+ tests_require=["pytest"],
+ **kwargs
+ )
diff --git a/dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch b/dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch
new file mode 100644
index 000000000000..1a84400a8d78
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.4.4-sphinx-theme.patch
@@ -0,0 +1,13 @@
+diff --git a/doc/conf.py b/doc/conf.py
+index 906f0315..caca0c0c 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -100,7 +100,7 @@ pygments_style = "sphinx"
+
+ # The theme to use for HTML and HTML Help pages. See the documentation for
+ # a list of builtin themes.
+-html_theme = "python_docs_theme"
++html_theme = "nature"
+
+ # Theme options are theme-specific and customize the look and feel of a theme
+ # further. For a list of options available for each theme, see the
diff --git a/dev-python/pylint/files/pylint-2.4.4-tests.patch b/dev-python/pylint/files/pylint-2.4.4-tests.patch
new file mode 100644
index 000000000000..b11ecb7c505b
--- /dev/null
+++ b/dev-python/pylint/files/pylint-2.4.4-tests.patch
@@ -0,0 +1,13 @@
+diff --git a/tests/unittest_lint.py b/tests/unittest_lint.py
+index 4f942cd0..d54008bf 100644
+--- a/tests/unittest_lint.py
++++ b/tests/unittest_lint.py
+@@ -792,7 +792,7 @@ def test_filename_with__init__(init_linter):
+ messages = reporter.messages
+ assert len(messages) == 0
+
+-
++@pytest.mark.skip("known failure, see https://github.com/PyCQA/pylint/issues/3198")
+ def test_by_module_statement_value(init_linter):
+ """Test "statement" for each module analized of computed correctly."""
+ linter = init_linter
diff --git a/dev-python/pylint/pylint-2.4.4.ebuild b/dev-python/pylint/pylint-2.4.4.ebuild
new file mode 100644
index 000000000000..7bffb5ac54f4
--- /dev/null
+++ b/dev-python/pylint/pylint-2.4.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+DISTUTILS_USE_SETUPTOOLS=rdepend
+# entry_points is added via **kwargs in a dict
+_DISTUTILS_SETUPTOOLS_WARNED=1
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python code static checker"
+HOMEPAGE="https://www.logilab.org/project/pylint
+ https://pypi.org/project/pylint/
+ https://github.com/pycqa/pylint"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/astroid-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/isort-4.2.5[${PYTHON_USEDEP}]
+ dev-python/mccabe[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/six[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.4-sphinx-theme.patch"
+ "${FILESDIR}/${PN}-2.4.4-no-pytest-runner.patch"
+ "${FILESDIR}/${PN}-2.4.4-tests.patch"
+)
+
+distutils_enable_sphinx doc
+distutils_enable_tests pytest
+
+python_install_all() {
+ doman man/{pylint,pyreverse}.1
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ # Optional dependency on "tk" USE flag would break support for Jython.
+ optfeature "pylint-gui script requires dev-lang/python with \"tk\" USE flag enabled." 'dev-lang/python[tk]'
+}