summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-08-13 10:45:49 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-08-13 10:45:49 -0500
commit2961a32774cd9e766ec631390993f3d97eb66c76 (patch)
tree15dc219f6cf1e1772312cdb3603f7b79ac7a8c69 /dev-python
parentdev-python/monotonic: remove version 0.2 (diff)
downloadgentoo-2961a32774cd9e766ec631390993f3d97eb66c76.tar.gz
gentoo-2961a32774cd9e766ec631390993f3d97eb66c76.tar.bz2
gentoo-2961a32774cd9e766ec631390993f3d97eb66c76.zip
dev-python/stormpath: add version 2.4.4
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/stormpath-2.4.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
index 472995774db7..4c436e2b476b 100644
--- a/dev-python/stormpath/Manifest
+++ b/dev-python/stormpath/Manifest
@@ -1,3 +1,4 @@
DIST stormpath-2.4.0.tar.gz 4345415 SHA256 4c3ee97bf630f0fb9237bccedfd4c41997a47599d76d319cfb84e95d7ec26db6 SHA512 4086c03b745427fa59d6b3739da38822781587d9d55bb0ea142dc70b9dd38ca98e8fdfbb167af6944440e7241ba63b2a2f58130b48789998fa3e263f11326a2b WHIRLPOOL 3425301a9c1858f5a602196be53e7a61961922786356f54f9fa3f033bb1b6460ad9ff32e4e0f2252e8b8220bd129fae5b8613771466f015e797b86d263391000
DIST stormpath-2.4.1.tar.gz 4345634 SHA256 5c07c27ff08527920878e7a350bd6532198e066badf929d70d46937684399e64 SHA512 50fbe12015b3dcc70c13de65d0a594684bb605f24f3aaf60bb51b7ff9e01346e6dece994ebccf790e58fe66c90aad252c4ef4c33b24f1b98172e1634fb733b95 WHIRLPOOL 332080e7c6c2ec7535e8eb51e132ac3df7f18fc65565e25b769f25cd5cd7d65c4b1d28da0c2b186250d8b58b6618bb5b27ccd1c1e6148365ad1139c7d5d39f4f
DIST stormpath-2.4.2.tar.gz 4345932 SHA256 17fb42c24c39830bb39589eff757e3b5c9d09d74c88dba520fa1031b5785e3ff SHA512 0b63308f179f83e409c24dabd75b96b0384b0eae4f729c1351e16c1158a61548c218e94e6d68fab196b6166e67a9132173205d52d03af334d690315f7756efff WHIRLPOOL 536a5899ba68788cd8a4b7c1acebf5126a301e52643da3e66fa7bd26f23b38c3a58adf271db03fa1eb92332c4bac83a4cb434027684c7b46ee53c1de5d69eaca
+DIST stormpath-2.4.4.tar.gz 4347668 SHA256 6630abba74bc5de5f295b78fd1c32a60a9d1f3b09863ce4353ea568a99fc175c SHA512 41c06dc8c96f363493777e4d65a559d12af0b4fc85e5bdd1a799d7191f24d06e4c1bad5364771e5aff5788e896a4d8bc5dd9209243f558062444da5201e21747 WHIRLPOOL a9277465fb21d127c7b75f4836ee89b5c98203b68af12b46bb9cb82842a79c7f8c6fc82533b677bd2815d8e5d88007ea44dc82cc8c40af3fe2fbca5883a2cb89
diff --git a/dev-python/stormpath/stormpath-2.4.4.ebuild b/dev-python/stormpath/stormpath-2.4.4.ebuild
new file mode 100644
index 000000000000..82cb332bb003
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.4.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ <=dev-python/oauthlib-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ esetup.py docs
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}