summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-24 23:14:29 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-24 23:14:29 +0100
commit2ad680a5d620244826364b72c21eb8a75b1aa06b (patch)
treee94c4c54b41fa0fe45d6aa53959d9eda7c63f30b /dev-python
parentdev-python/prompt_toolkit: Remove old (diff)
downloadgentoo-2ad680a5d620244826364b72c21eb8a75b1aa06b.tar.gz
gentoo-2ad680a5d620244826364b72c21eb8a75b1aa06b.tar.bz2
gentoo-2ad680a5d620244826364b72c21eb8a75b1aa06b.zip
dev-python/pytest-cov: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.11.0.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index e12fb77fb050..368a96d8db11 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,2 +1 @@
-DIST pytest-cov-2.11.0.tar.gz 59018 BLAKE2B f2ecaff439e701c3b7d029e4c51cb019d5222a083815ae5771341b0fa0f1b658f921a6eab75c0b568b630cc7ca75887f25ae7fb6fcaa9c2e8dc419397c4c799a SHA512 001f4975d7ad1a573354074366f983887ec9035bcc29afe9bd1ae2654fab520b8f479c5037936e6131749e5205077e937304e73d366cb43460db1f24a58b02be
DIST pytest-cov-2.11.1.tar.gz 59143 BLAKE2B 21aeffbc9ccbe6a7c69a08fe3f0013204eb039c6dc9ddbb364a74ad10764e16ce7be0154e27beaab2c8f9b2a972131c4c2421c4aa4557efc18318556056a421b SHA512 19c465f5972ee0ee3b9a2f1a656fdf5457622cb449f73a6f707d377a617807dadda997a6875f0c081bc4c4f7039559c6e7ce820b818db42dfd053c016e1c3b4e
diff --git a/dev-python/pytest-cov/pytest-cov-2.11.0.ebuild b/dev-python/pytest-cov/pytest-cov-2.11.0.ebuild
deleted file mode 100644
index 60cf89a6e397..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.11.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
-"
-# TODO: figure out how to make tests work without pytest-cov installed
-# first
-BDEPEND="
- test? (
- ~dev-python/pytest-cov-${PV}[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme
-
-python_test() {
- local deselect=(
- # attempts to install packages via pip (network)
- tests/test_pytest_cov.py::test_dist_missing_data
- )
-
- pytest -vv ${deselect[@]/#/--deselect } || die "Tests failed under ${EPYTHON}"
-}