summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-11-27 01:47:12 -0500
committerTim Harder <radhermit@gentoo.org>2017-11-27 02:00:21 -0500
commit2ca17dda3c13e863fb5047753c4a58890ef65579 (patch)
tree910774ecfa41fe3ecba7452385ec3b9fbe3d4971 /dev-python
parentmedia-gfx/pycam: Removed old version (diff)
downloadgentoo-2ca17dda3c13e863fb5047753c4a58890ef65579.tar.gz
gentoo-2ca17dda3c13e863fb5047753c4a58890ef65579.tar.bz2
gentoo-2ca17dda3c13e863fb5047753c4a58890ef65579.zip
dev-python/wstools: add py36 support, fix deps, and enable test phase
Also, re-add all the dropped keywords due to the previously added, unnecessary deps.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wstools/files/wstools-0.4.5-setup.patch46
-rw-r--r--dev-python/wstools/wstools-0.4.5-r1.ebuild34
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/wstools/files/wstools-0.4.5-setup.patch b/dev-python/wstools/files/wstools-0.4.5-setup.patch
new file mode 100644
index 000000000000..9de7c159c972
--- /dev/null
+++ b/dev-python/wstools/files/wstools-0.4.5-setup.patch
@@ -0,0 +1,46 @@
+Avoid pulling in a lot of unnecessary test and setup deps.
+
+--- wstools-0.4.5/setup.py
++++ wstools-0.4.5/setup.py
+@@ -9,7 +9,7 @@
+
+ from setuptools import setup, find_packages, Command
+ from setuptools.command.test import test as TestCommand
+-from pip.req import parse_requirements
++#from pip.req import parse_requirements
+
+ NAME = "wstools"
+ url = "https://github.com/pycontribs/wstools.git"
+@@ -55,13 +55,13 @@
+
+ def run_tests(self):
+ # before running tests we need to run autopep8
+- try:
+- subprocess.check_call(
+- "python -m autopep8 -r --in-place wstools/ tests/",
+- shell=True)
+- except subprocess.CalledProcessError:
+- logging.getLogger().warn('autopep8 is not installed so '
+- 'it will not be run')
++ # try:
++ # subprocess.check_call(
++ # "python -m autopep8 -r --in-place wstools/ tests/",
++ # shell=True)
++ # except subprocess.CalledProcessError:
++ # logging.getLogger().warn('autopep8 is not installed so '
++ # 'it will not be run')
+ # import here, cause outside the eggs aren't loaded
+ import pytest # noqa
+ errno = pytest.main(self.pytest_args)
+@@ -136,9 +136,9 @@
+ cmdclass={'test': PyTest, 'release': Release, 'prerelease': PreRelease},
+ packages=find_packages(exclude=['tests']),
+ include_package_data=True,
+- tests_require=get_requirements(base_path, 'requirements-dev.txt'),
++ #tests_require=get_requirements(base_path, 'requirements-dev.txt'),
+ setup_requires=['setuptools'],
+- install_requires=get_requirements(base_path, 'requirements.txt'),
++ install_requires=['six'],
+
+ license='BSD',
+ description="WSDL parsing services package for Web Services for Python. see" + url,
diff --git a/dev-python/wstools/wstools-0.4.5-r1.ebuild b/dev-python/wstools/wstools-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..9a3d508f201b
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.python.org/pypi/wstools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}"/${P}-setup.patch )
+
+python_test() {
+ esetup.py test
+}