summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-05 09:52:06 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-05 11:41:07 +0200
commit2f98c979dc2b9a27f304bc042d4e1950d63a964f (patch)
treeb0a570b98b5293c5643cd8c18c9fac99d10852b0 /dev-python
parentdev-python/django: Bump to 3.2.16 (diff)
downloadgentoo-2f98c979dc2b9a27f304bc042d4e1950d63a964f.tar.gz
gentoo-2f98c979dc2b9a27f304bc042d4e1950d63a964f.tar.bz2
gentoo-2f98c979dc2b9a27f304bc042d4e1950d63a964f.zip
dev-python/discogs-client: Bump 2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/discogs-client/Manifest1
-rw-r--r--dev-python/discogs-client/discogs-client-2.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/discogs-client/Manifest b/dev-python/discogs-client/Manifest
index 3d45913d2a3b..9e78eb18cfdd 100644
--- a/dev-python/discogs-client/Manifest
+++ b/dev-python/discogs-client/Manifest
@@ -1,2 +1,3 @@
DIST python3-discogs-client-2.3.15.tar.gz 35059 BLAKE2B fe2b577b4810480fcad8a76c8f961809baa5b217c0d01c262f4a6a0a2993b2a6d2515edf90f276f7a104f6bdf0a1edb0f439c69e51507e3c0cf1ab927049e7f7 SHA512 8da52cc6c125cc4b3c5fb93626075ba32046798f71f72cc9f685fdf10a92a813fbd74b35625994cd4c6b7e394e36265ce01a33b52b607bf498a5f11f68d82ad9
DIST python3-discogs-client-2.4.tar.gz 35724 BLAKE2B 98976cb4bd52c459ab63e5d178bc0a7eb2c6ee56ff866d2248b326423a9b7f5187ed348d3cfa67d2aa38b1f4cc107367351e40408b9f577ecec27f28724d9be3 SHA512 96a3f1e653c95751b790f58dae2efd7e33a1af581a945327704a31df96e99dad543ca978c4e42f6f05824f6f74ccfcf7fe5e59e46c82df1634a655581d833442
+DIST python3-discogs-client-2.5.tar.gz 36003 BLAKE2B e2350cc2eed986566be79ce3b529885113739da6b42f77dd405456e0552a68d51d1945f3ba569e05b9afc6304233a8b5ebe7c9f4f8105d62d9d159da7a0ff3ec SHA512 d6c90d6f0b472cdeda2a0d019386e3ab609ff46a82c3eefcd9b69162e1f94b34d58916dfb2364afb8cd9def0bf11e60cbed2e2c2dbb03206ea9a0faf141aa4ec
diff --git a/dev-python/discogs-client/discogs-client-2.5.ebuild b/dev-python/discogs-client/discogs-client-2.5.ebuild
new file mode 100644
index 000000000000..c8b04833cbf4
--- /dev/null
+++ b/dev-python/discogs-client/discogs-client-2.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/p/python3-${PN}/python3-${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/python3-${P}"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="
+ https://github.com/joalla/discogs_client/
+ https://pypi.org/project/python3-discogs-client/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest