summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-06-05 18:45:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-06-05 19:10:12 +0300
commit3030a50c9ecc2c5b3ce0db6037aecec3cff79ac3 (patch)
tree699d7783bb56a83f3a2e1c0c6b1e65a36e07f9ff /dev-python
parentdev-python/pytest-plus: enable py3.11 (diff)
downloadgentoo-3030a50c9ecc2c5b3ce0db6037aecec3cff79ac3.tar.gz
gentoo-3030a50c9ecc2c5b3ce0db6037aecec3cff79ac3.tar.bz2
gentoo-3030a50c9ecc2c5b3ce0db6037aecec3cff79ac3.zip
dev-python/pyotp: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyotp/pyotp-2.6.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pyotp/pyotp-2.6.0-r1.ebuild b/dev-python/pyotp/pyotp-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..91f2c3bb010d
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.6.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords"
+HOMEPAGE="https://github.com/pyauth/pyotp
+ https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest