summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2021-01-30 20:53:10 +0100
committerConrad Kostecki <conikost@gentoo.org>2021-01-30 21:26:33 +0100
commit326239d77fa37683adb26c1d432e90a9db0059d3 (patch)
treef78d36972a68c18a56c468988d3bfc75dbd40539 /dev-python
parentdev-python/django-cors-headers: bump to version 3.7.0 (diff)
downloadgentoo-326239d77fa37683adb26c1d432e90a9db0059d3.tar.gz
gentoo-326239d77fa37683adb26c1d432e90a9db0059d3.tar.bz2
gentoo-326239d77fa37683adb26c1d432e90a9db0059d3.zip
dev-python/django-filter: bump to version 2.4.0
Also added up to python3_9 support. Closes: https://bugs.gentoo.org/766998 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-filter/Manifest1
-rw-r--r--dev-python/django-filter/django-filter-2.4.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/django-filter/Manifest b/dev-python/django-filter/Manifest
index d0cd3576913c..7e9445a77aeb 100644
--- a/dev-python/django-filter/Manifest
+++ b/dev-python/django-filter/Manifest
@@ -1 +1,2 @@
DIST django-filter-2.2.0.tar.gz 142804 BLAKE2B f2385fe3afa78349395bd3334461ad2acc760a2007d4b69618993e176899c77e8585d90bb68578e561a16459cdf35a480adf0a0e6235d6500e5f2c2a7c602445 SHA512 16a4336d1558cabfe497dd9736a2f652c9f9d141a72c856cf13f3ca56db4da85b5926b05c772aef5fa43a75e085025244b8deaf7facbc5bfa68907bd99f4f95d
+DIST django-filter-2.4.0.tar.gz 146904 BLAKE2B 994b07c0f5e511451964f4f1e007ff9906975600d0bc8a02dcbeb86f91bf906490ca394ca95c23c57c1fff25a447f50a40054c0abfe385300f9db87645753978 SHA512 0584222b46add89aa7dd1dfd334fdd19903e0119d455a2c46644c501a66df224f9f51c33394d130bcd1fc0f28c6ede6d6853b9790430040ec7228f9a1dc55264
diff --git a/dev-python/django-filter/django-filter-2.4.0.ebuild b/dev-python/django-filter/django-filter-2.4.0.ebuild
new file mode 100644
index 000000000000..d79fbac04dc3
--- /dev/null
+++ b/dev-python/django-filter/django-filter-2.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Django app allowing declarative dynamic QuerySet filtering from URL parameters"
+HOMEPAGE="https://github.com/carltongibson/django-filter"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/django-1.11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest