summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-07-07 20:29:37 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2018-07-07 20:29:56 -0500
commit338e8fe2e7d95c145476ba06649fbc59089aac77 (patch)
tree780aee21196968d04d9a65e21a44debc8c565c6f /dev-python
parentdev-python/hacking: fix testtools dep (diff)
downloadgentoo-338e8fe2e7d95c145476ba06649fbc59089aac77.tar.gz
gentoo-338e8fe2e7d95c145476ba06649fbc59089aac77.tar.bz2
gentoo-338e8fe2e7d95c145476ba06649fbc59089aac77.zip
dev-python/testtools: clean up old
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/testtools/Manifest2
-rw-r--r--dev-python/testtools/testtools-0.9.36.ebuild50
-rw-r--r--dev-python/testtools/testtools-1.8.0.ebuild52
3 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/testtools/Manifest b/dev-python/testtools/Manifest
index c88d2072039e..04cb4cdd6ce9 100644
--- a/dev-python/testtools/Manifest
+++ b/dev-python/testtools/Manifest
@@ -1,3 +1 @@
-DIST testtools-0.9.36.tar.gz 201717 BLAKE2B 3acfc2b3a821919728670868a44356e93536a1d9530b396d5964a44879246d825358f5abe03041679ab8a48b90670757895c32a5ea47bdc6752c20f1ce83e075 SHA512 1cb29deb2fb7cd0eebd9affb06e877487989163d0c4452db8051d75b936b0c4ac6443649d52f83cd3695421b361af7dc75507b037528ac0f7cfde9b4b201ad08
-DIST testtools-1.8.0.tar.gz 207976 BLAKE2B eaa651436f289710f84910ac8229f8635db4e7129f58495a2efeea4f944befaf93f05992f5d666108845db5d4079ee55e371be5c3f5b403ad56998053c601b5d SHA512 b5f0201222d1e8c60fb7c2793bcd38e1c96c6f9fae99e9f3e784d17230c9abbf7325053d501c07e752bad2da36b49e2c79a25d0c20cb9a2f426057f839a77b3a
DIST testtools-2.3.0.tar.gz 231559 BLAKE2B 6ae098e368cabc0bfe45736324819687a6086eccf868de7eec312caf7c64b5d75a3168f3966d5cd0b05ad9295957a7aa1ee3c1589f076de1f5cb619b197ba08a SHA512 558fe6a1bdce7215f9f6f178f469a2b76948dc7ff0ce27400482a16683474edb81d9bf90ae48b6fcb8df9eb70759341b694aa162ed3d9d4abd372981cdcd8a64
diff --git a/dev-python/testtools/testtools-0.9.36.ebuild b/dev-python/testtools/testtools-0.9.36.ebuild
deleted file mode 100644
index 3c816291c9e1..000000000000
--- a/dev-python/testtools/testtools-0.9.36.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 versionator
-
-#SERIES="$(get_version_component_range 1-2)"
-SERIES="trunk"
-
-DESCRIPTION="Extensions to the Python unittest library"
-HOMEPAGE="https://launchpad.net/testtools https://pypi.org/project/testtools/"
-SRC_URI="https://launchpad.net/${PN}/${SERIES}/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="dev-python/mimeparse[${PYTHON_USEDEP}]
- dev-python/extras[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( $(python_gen_cond_dep 'dev-python/twisted-core[${PYTHON_USEDEP}]' python2_7) )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_prepare_all() {
- # Take out failing tests
- # https://bugs.launchpad.net/testtools/+bug/1380918
- sed -e 's:test_test_module:_&:' -e 's:test_test_suite:_&:' \
- -i testtools/tests/test_distutilscmd.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/testtools/testtools-1.8.0.ebuild b/dev-python/testtools/testtools-1.8.0.ebuild
deleted file mode 100644
index 33c0a7d8f7e6..000000000000
--- a/dev-python/testtools/testtools-1.8.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Extensions to the Python standard library unit testing framework"
-HOMEPAGE="https://github.com/testing-cabal/testtools"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-CDEPEND="
- dev-python/extras[${PYTHON_USEDEP}]
- dev-python/mimeparse[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- >=dev-python/unittest2-1.0.0[${PYTHON_USEDEP}]
- dev-python/traceback2[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-RDEPEND="${CDEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-twisted-backport.patch
- "${FILESDIR}"/${P}-twisted-backport1.patch
- "${FILESDIR}"/${P}-twisted-backport2.patch
-)
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- "${PYTHON}" -m testtools.run testtools.tests.test_suite || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( doc/_build/html/. )
-
- distutils-r1_python_install_all
-}