summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-20 07:20:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-20 07:38:58 +0200
commit33ee092cb8ec01678206e1ce0b4ac6749bdce035 (patch)
treeac2f8c7055c447ac1dadb8a920f763d54d00798b /dev-python
parentdev-python/bitarray: Bump to 2.6.0 (diff)
downloadgentoo-33ee092cb8ec01678206e1ce0b4ac6749bdce035.tar.gz
gentoo-33ee092cb8ec01678206e1ce0b4ac6749bdce035.tar.bz2
gentoo-33ee092cb8ec01678206e1ce0b4ac6749bdce035.zip
dev-python/python-daemon: Bump to 2.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-daemon/Manifest1
-rw-r--r--dev-python/python-daemon/python-daemon-2.3.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-daemon/Manifest b/dev-python/python-daemon/Manifest
index 376cbac9a72b..3e6801efb6fb 100644
--- a/dev-python/python-daemon/Manifest
+++ b/dev-python/python-daemon/Manifest
@@ -1 +1,2 @@
DIST python-daemon-2.3.0.tar.gz 82831 BLAKE2B 6e7fa082a513827283f46044347dfd445633db0d1781a33aa1bc5b14c340da784310ae6bd07d6cf3673cd05cb14a9d090ab51857d26cca52d09bc8c3b195360f SHA512 30bb70821aae720d09032c8c666524fa9a1a486314ffff73eb161231a1f2b954914295b4ad41f9c8529bc045fb6d0f89256bc59f8979a4f8a6698e9bd4d7441a
+DIST python-daemon-2.3.1.tar.gz 82856 BLAKE2B d1ede5fde50f179b0bf3e3ed89bd988469bae1f57667ab601d44452706a84264f55fc9beb89226e5fb1bb6d92f88fc2a5c2497628de16990407a0e01cfbacd84 SHA512 128fd8ac125eac613936668bb555635c8cec576d5c23513210f0956983c70720dd93906adeee581b192b57480a3df93dc1e08f6f7b62e38b2404fa00aba4805a
diff --git a/dev-python/python-daemon/python-daemon-2.3.1.ebuild b/dev-python/python-daemon/python-daemon-2.3.1.ebuild
new file mode 100644
index 000000000000..61b277f6fec1
--- /dev/null
+++ b/dev-python/python-daemon/python-daemon-2.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to implement a well-behaved Unix daemon process"
+HOMEPAGE="https://pypi.org/project/python-daemon/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+# build system and tests use GPL-3.0+ but none of these files are installed
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/lockfile[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/twine[${PYTHON_USEDEP}]
+ test? (
+ dev-python/testtools[${PYTHON_USEDEP}]
+ dev-python/testscenarios[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest