summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-07-25 19:26:23 +0200
committerAaron Bauman <bman@gentoo.org>2020-07-25 18:12:39 -0400
commit33ffdd2872d37aaf3181d7a528ba6c587afe616b (patch)
treeac1a32289fe3f9925c363ce1aaa4728a3d6ee12f /dev-python
parentsys-libs/glibc: remove old (diff)
downloadgentoo-33ffdd2872d37aaf3181d7a528ba6c587afe616b.tar.gz
gentoo-33ffdd2872d37aaf3181d7a528ba6c587afe616b.tar.bz2
gentoo-33ffdd2872d37aaf3181d7a528ba6c587afe616b.zip
dev-python/aiofiles: add 0.5.0
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16819 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/aiofiles/Manifest1
-rw-r--r--dev-python/aiofiles/aiofiles-0.5.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/aiofiles/Manifest b/dev-python/aiofiles/Manifest
index ca27e48131e6..601a81ef32ad 100644
--- a/dev-python/aiofiles/Manifest
+++ b/dev-python/aiofiles/Manifest
@@ -1 +1,2 @@
DIST aiofiles-0.4.0.tar.gz 12942 BLAKE2B c8e6570f0759cf97b642a8feec4a572dc40a86906c9f7e749fa5b20346b61000d62d72c1ef8316e03adc1352021ec622fe9c670e916fdf84f41845ce37f1de51 SHA512 9e1f8b2beb3ca2996b35de9281ceafbb8ccdeab4b213f9605cb5908558c5f495d1cf4481ac229ca44bb236ad99826d89d137ec6ac4386c23b6e056b657a6bf4a
+DIST aiofiles-0.5.0.tar.gz 13332 BLAKE2B ccd044ce9fcd74b2a6419b4f0e9e3977086c9685741dbb734a7f9222ab96dca58b5330ad0d0cd9f10fce03ee123add7101825f047451344fc451c40a4352674e SHA512 89eb1af506bdf5f3f2e9c3afe90f17d521ada1cdeb449dcdc800d4faa4edc1c9ca93811915aa059d8c5a1b0a3aaa40231a46b3d041ca745e071628293bddf1b7
diff --git a/dev-python/aiofiles/aiofiles-0.5.0.ebuild b/dev-python/aiofiles/aiofiles-0.5.0.ebuild
new file mode 100644
index 000000000000..986e5ea1c6ff
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-0.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="https://github.com/Tinche/aiofiles"
+SRC_URI="https://github.com/Tinche/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="test? (
+ >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest