summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:48:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 11:02:19 +0100
commit34608a71618411d5b607289faa9b99abd1a4c5f6 (patch)
tree15074aa2117aaf6cc7255b37e48f4705ef74864f /dev-python
parentdev-python/tinycss2: Switch to PEP 517 build (diff)
downloadgentoo-34608a71618411d5b607289faa9b99abd1a4c5f6.tar.gz
gentoo-34608a71618411d5b607289faa9b99abd1a4c5f6.tar.bz2
gentoo-34608a71618411d5b607289faa9b99abd1a4c5f6.zip
dev-python/tomli-w: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild b/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..d45b2248a1e7
--- /dev/null
+++ b/dev-python/tomli-w/tomli-w-1.0.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A lil' TOML writer"
+HOMEPAGE="
+ https://pypi.org/project/tomli-w/
+ https://github.com/hukkin/tomli-w/"
+SRC_URI="
+ https://github.com/hukkin/tomli-w/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? ( dev-python/tomli[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest