summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-31 09:12:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-31 09:26:17 +0200
commit3493d19309ed71953217eb263d13a97830ccd7f6 (patch)
tree995e04b2c86ab300448e1b268e98094bcd58bffe /dev-python
parentdev-python/hpack: Bump to 4.0.0 (diff)
downloadgentoo-3493d19309ed71953217eb263d13a97830ccd7f6.tar.gz
gentoo-3493d19309ed71953217eb263d13a97830ccd7f6.tar.bz2
gentoo-3493d19309ed71953217eb263d13a97830ccd7f6.zip
dev-python/hypothesis: Bump to 5.30.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.30.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 17285bfbc374..0511e73ca580 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -7,3 +7,4 @@ DIST hypothesis-python-5.28.0.tar.gz 9069739 BLAKE2B c7b404b815053441a7446c947a0
DIST hypothesis-python-5.29.0.tar.gz 9070261 BLAKE2B 38781893d6fdf68deae890a150ca07ba5d1fb3c9ba717ea356af8b0b10b21c7e6a4b94b1ec9bca7ba5cb02b0baa18c5a773892fac342767b6dd79cbf2f89bdad SHA512 e3fc350181f86bb9669d4b0d0a43291056550bb73545070e2c7931006393895e7010050f90a063935bedb60bd18a3bad904ca92b147d81254ab50d4868adc8d0
DIST hypothesis-python-5.29.3.tar.gz 9070885 BLAKE2B 6e106fbc6ed6719c787083c85e3047c49af94478148f4038b59d4ae130b272cffa86a2c117fd2a4f6a798255aa33b0f4714ec08baaf8fb1d5f1d0fb8d4de336a SHA512 fb820057ec257d4dd749f0c6caf10bdcc1e3a090c788900f159456620bec6bd2130e9ffad0ced0155a9f97e2186ed397fa72dbd5548b132ac2c129735c1e716d
DIST hypothesis-python-5.29.4.tar.gz 9071060 BLAKE2B 0668f3c7859fae7024c15f693b1f56ce8d02d6f3b8187d24b2d84e38e7bdb73c0824d2b02cfecc6b40bdfbbb1c91c0aa83d40848c499a97ab7e9223aaa6c78d4 SHA512 9da4b487fd3c56540a20e2fbff635704f0720f422d8a398d0accd24a1fb9517476b0d29135b9113a96e8dc98fcfc31cc53215ad82cb727be54e4e77b44d4c8e4
+DIST hypothesis-python-5.30.0.tar.gz 9071239 BLAKE2B 7d46bc588d35bee187d9c19fafb41b290edb0e4b40022bfcdf502f96631aca7afe3beb6c4f27df27784ab1ef9903df7747284253906140835429e62b19eb1904 SHA512 03423b48aee71eceb84d838433351b48abf041ed1a9b617ea3e0059e8046f1cafd327e4ed4ec65c7893340602ea7d21572b3a8bbd059b27e1d0c9b867a6938b0
diff --git a/dev-python/hypothesis/hypothesis-5.30.0.ebuild b/dev-python/hypothesis/hypothesis-5.30.0.ebuild
new file mode 100644
index 000000000000..9fb996f97f0a
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.30.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}