summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-30 08:52:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-30 09:14:19 +0200
commit3510ea63df6c109ce4a7469c3addd72db01193d0 (patch)
tree77a82d3ea1588c2f9dbd60ccea0e72fd97a8d1af /dev-python
parentdev-python/botocore: Bump to 1.18.8 (diff)
downloadgentoo-3510ea63df6c109ce4a7469c3addd72db01193d0.tar.gz
gentoo-3510ea63df6c109ce4a7469c3addd72db01193d0.tar.bz2
gentoo-3510ea63df6c109ce4a7469c3addd72db01193d0.zip
dev-python/boto3: Bump to 1.15.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.15.8.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 1667c6f4b3a5..d145e11ac874 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -9,3 +9,4 @@ DIST boto3-1.15.4.tar.gz 335401 BLAKE2B 42ee1f2cf1e82338ea59a40b95aa5c76abae51aa
DIST boto3-1.15.5.tar.gz 335536 BLAKE2B e4476272346dce929be52be220ac7da2e258bc20f5586eec8adb18bfedf1be63c6318a4ac9890d1380b625a67aa4ca5068fbccd6c36972a9ec8baf4473d1f2f1 SHA512 d9d49176b800f2fdf70ae3da657201571a26112f23b12337b133459c6e03d4f56970f6a7be3da6570439f32c41fc917adcc8c3b1d9cd74196728ac55ca0bb933
DIST boto3-1.15.6.tar.gz 335618 BLAKE2B 6f3816b6363757ea1dbdef4bd710a68f07b513d2f4b6a7ad05769e2417e8b0a6752dcff8f3600f8bb419f074a24b32c9386c9f11dc549097bd963c32d20a0d23 SHA512 7357f8ac98ca1bb1983af22537d1ed939b1e51371966a7c312ec748f6acf9fbbb102335965a79cf44ebbb2b0b4db9ce859c4470f542d19ceea4513d90eaba274
DIST boto3-1.15.7.tar.gz 335640 BLAKE2B 01becc9a36fc03937153fc7d4a37b5630bb1c1d6f72ff9420de73a05f4ef7e5e39561e4175b6f652241d15efae708123b41673d9d69453b9b902c0f1568282b1 SHA512 4b612fc51e453af77e84ddbe5d3ee8e03e25be37a2b8fe65a960c22b8ee3423b1ddf0a482a189378e470500b3fe78af615571f15f9fb8fa86147a4334ef22ffa
+DIST boto3-1.15.8.tar.gz 335724 BLAKE2B 4b034d21108bcf7fc100f71e534e348dfd72cf1ffea7e4ae53fa420e05c1e854216095e3179c4ce16c893a5bd32665830fc5ef3c3a4f0a011797b227ac53501d SHA512 dc6b9816fe58401a391aee2843698d8245141cb9735cc8b3c27181388ce8df070649e15d437ad96bbe3948061c97b0285e323c48e298c57271cd83d11180c768
diff --git a/dev-python/boto3/boto3-1.15.8.ebuild b/dev-python/boto3/boto3-1.15.8.ebuild
new file mode 100644
index 000000000000..ccc99e1c2415
--- /dev/null
+++ b/dev-python/boto3/boto3-1.15.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}