summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-17 00:21:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-17 00:37:01 +0200
commit3597c408ae6de57bdade8f9c0b0975704f8f1d9c (patch)
treeaed701fd9da1f504ada8254e3f7dad261ccc3da1 /dev-python
parentapp-admin/awscli: Bump to 1.20.1 (diff)
downloadgentoo-3597c408ae6de57bdade8f9c0b0975704f8f1d9c.tar.gz
gentoo-3597c408ae6de57bdade8f9c0b0975704f8f1d9c.tar.bz2
gentoo-3597c408ae6de57bdade8f9c0b0975704f8f1d9c.zip
dev-python/fonttools: Bump to 4.25.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fonttools/Manifest1
-rw-r--r--dev-python/fonttools/fonttools-4.25.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/fonttools/Manifest b/dev-python/fonttools/Manifest
index a963170284ef..0c4f5f52e2b1 100644
--- a/dev-python/fonttools/Manifest
+++ b/dev-python/fonttools/Manifest
@@ -1,2 +1,3 @@
DIST fonttools-4.24.4.tar.gz 2556059 BLAKE2B c415ae5214b6df7171a5f8a7ea179b1a4adbc6646598d773f0d3d6a8cd777e8fd3c74c14f00e6c4735a73e712e3fd42ddfc96f3f101d34b122fb9c471d4d94a3 SHA512 aa4ee8f0a7f9cb6d8a84497e6f33f891491cd06cc477a785715f8fde8e5b33cf781ef8b848bfab8cf9a97fc15c018d493c6baf0fb8fd314b8a348c36ff627f41
DIST fonttools-4.25.0.tar.gz 2576777 BLAKE2B 802236b120ae78e2721d734875fba794fb9eafc125fbfea6b70c68d6a18a8b3c1ce685da18c83ee3364ff38f72707e42ed0ae25bc62d362c6271fff90da56d0c SHA512 c8f7512053ce611fa07bbc1fe844ee9d50cf09e19a2a27bed7df9d37d362b7daa910fbb651147f3690a03ec4d8adc8d96e8f0310eda24bb40208240182dc9b54
+DIST fonttools-4.25.1.tar.gz 2577170 BLAKE2B 8cb03ef1f9cf4e61d5e6d4963bb5c43ec48838e0453cc293de1c763a29b34d69701b87430d8a85085f06c26671e00a91c89e4c50ba8d2fad4a9cc72b1f17d0e9 SHA512 ca3732bcc5e2b373983d34bd72e0ea36488f24aa442d25d0d16f6a473ef35323547f900b1ae87c42e64c451afe4f760291095738a4442c11c5566c9efd0aa944
diff --git a/dev-python/fonttools/fonttools-4.25.1.ebuild b/dev-python/fonttools/fonttools-4.25.1.ebuild
new file mode 100644
index 000000000000..e40813acd252
--- /dev/null
+++ b/dev-python/fonttools/fonttools-4.25.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
+HOMEPAGE="https://github.com/fonttools/fonttools/"
+SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+RDEPEND=">=dev-python/fs-2.4.9[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ app-arch/zopfli
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # When dev-python/pytest-shutil is installed, we get weird import errors.
+ # This is due to incomplete nesting in the Tests/ tree:
+ #
+ # Tests/feaLib/__init__.py
+ # Tests/ufoLib/__init__.py
+ # Tests/svgLib/path/__init__.py
+ # Tests/otlLib/__init__.py
+ # Tests/varLib/__init__.py
+ #
+ # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
+ touch Tests/svgLib/__init__.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # virtualx used when matplotlib is installed causing plot module tests to run
+ virtx epytest Tests fontTools
+}