summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-03-23 00:34:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-03-23 00:36:48 -0500
commit35d425c647e99aa77f8d49e72637db02903ef09f (patch)
tree967485231757391c97e55992817f399613b068a7 /dev-python
parentapp-text/libgxps: bump to 0.2.5 (diff)
downloadgentoo-35d425c647e99aa77f8d49e72637db02903ef09f.tar.gz
gentoo-35d425c647e99aa77f8d49e72637db02903ef09f.tar.bz2
gentoo-35d425c647e99aa77f8d49e72637db02903ef09f.zip
dev-python/pbr: 2.0.0 bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-2.0.0.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index f83ffa614274..aa0ad750e5b3 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -2,3 +2,4 @@ DIST pbr-0.8.2.tar.gz 77790 SHA256 eef2ace8d65d5902582cbc9ad3b2ecff0e86a6f90ad48
DIST pbr-1.10.0.tar.gz 111425 SHA256 186428c270309e6fdfe2d5ab0949ab21ae5f7dea831eab96701b86bd666af39c SHA512 f7f6ce2f70324e2d287f58c3d12e0be2e33ef9ed32311ad2c56410eb67cda20732adff2058ba2fc244249a17a4c95b0d589ba913db4777e63ff1023ae888c864 WHIRLPOOL d70893921cabccf0e147ba1203cc2838feb47afcda90f7b584eb997dc4ae7e30e47b93b04ddaae8215bfa78351a5a2a53bfca5dc9fbb1ee7a268ae166c73c222
DIST pbr-1.8.1.tar.gz 104584 SHA256 e2127626a91e6c885db89668976db31020f0af2da728924b56480fc7ccf09649 SHA512 909b3ef463787d68f75f300b483ffb7d1e54ef246ed893ab5cf84e5489e171b67b77c90a1f90259ca274eeb286a66a3f221d5e0c17df5d14d0aa263d36ba6eb4 WHIRLPOOL 69bf79cc322583b17e86ccb130894dbd5aed4b0b6c8c273c977a3a5ac79190cd15b96b28d76995021eb69c30b76bcf7e9a061c0280483da9ec0c69d33e9f0822
DIST pbr-1.9.1.tar.gz 113439 SHA256 3997406c90894ebf3d1371811c1e099721440a901f946ca6dc4383350403ed51 SHA512 02c05652ee7504ec45330ab281be5880d70aa8017b1181446323d811b97e0c2deb6b3ff693516e32dd9ba2ecc653b13dbe33114e52414e78a478f5374b195cf1 WHIRLPOOL 73b87af217dc6af2bc14b2235a5d7f5f4ac1dd3fe3c0ede5730961e65aa0bd04194731c22cdf66567401f04600f5258dc9d3006e3ac9bc89e3743fa1415c099c
+DIST pbr-2.0.0.tar.gz 98568 SHA256 0ccd2db529afd070df815b1521f01401d43de03941170f8a800e7531faba265d SHA512 39540f54de674d4e50d6e9239328c0ac11ae6218a1483b023ab282efb797fc143d22334f60697ba81e2309c525860525ed0ce4858d66b187d2581fab9fae6b7d WHIRLPOOL 049df8e4fee3c65c04362cbbcda88047f9fa672caa1d1319bac5dfdf2452ddfd442e9e46bc832fad57831844eed1f0da4267fe3ae40b148948a9413aa5b155a2
diff --git a/dev-python/pbr/pbr-2.0.0.ebuild b/dev-python/pbr/pbr-2.0.0.ebuild
new file mode 100644
index 000000000000..400dd091fffc
--- /dev/null
+++ b/dev-python/pbr/pbr-2.0.0.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.5.1[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-13.1.0[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+PDEPEND=""
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # This test passes when run within the source and doesn't represent a failure, but rather
+ # a gentoo sandbox constraint
+ # Rm tests that rely upon the package being already installed and fail
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -e s':test_sdist_extra_files:_&:' \
+ -e s':test_command_hooks:_&:' \
+ -e s':test_sdist_git_extra_files:_&:' \
+ -i pbr/tests/test_core.py || die
+ sed -e s':test_command_hooks:_&:' \
+ -e s':test_global_setup_hooks:_&:' \
+ -i pbr/tests/test_hooks.py || die
+ sed \
+ -e "s:test_wsgi_script_install:_&:" \
+ -i pbr/tests/test_wsgi.py || die
+ einfo "rogue tests disabled"
+ sed -i '/^hacking/d' test-requirements.txt || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}